Go Back   Ford Truck Enthusiasts Forums > Misc. > Electrical Systems/Wiring
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-17-2014, 04:38 PM
dlsoc3 dlsoc3 is offline
New User
 
Join Date: Aug 2014
Posts: 2
dlsoc3 is starting off with a positive reputation.
2004 expedition speedometer and shifting problem

I have a 2004 expedition with the 5.4l engine. The truck was built with 2003 parts however...it has the 4R70W transmission. The transmission failed and I replaced it with a junk yard transmission. After installing the new transmission my speedometer has stopped working and the truck will not shift past second gear. I removed the speed sensor from my original transmission and it still has not solved the problem. Does anyone have any insight to what may be happening? Cruise control will not light up on dash either.

Thank you
Reply With Quote
  #2  
Old 08-17-2014, 08:02 PM
Franklin2's Avatar
Franklin2 Franklin2 is offline
Moderator
 
Join Date: Jan 2001
Location: Staunton VA
Posts: 32,819
Franklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant future
Take it to autozone or someplace like that and get them to read the codes. If you still have a VSS error code, you need to figure out why.
__________________
Dave F

1989 F250 XLT Diesel
Reply With Quote
Old 08-17-2014, 08:02 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Misc. > Electrical Systems/Wiring

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 expedition speedometer and shifting problem dlsoc3 Expedition & Navigator 1 08-18-2014 05:36 PM
E4OD speedo issues kdennie1334 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 1 07-04-2014 08:55 PM
94 Bronco Speedometer and shift problem BrentsSF 1978 - 1996 Big Bronco 5 01-04-2005 11:19 PM
97 Expedition Guages,Speedometer,Shifting Hard GW1968 Expedition & Navigator 11 09-14-2004 07:07 AM
Auto Trans. With Bigger Tires Pickupman2004 Super Duty & Heavy Duty 1 03-03-2004 08:16 AM



All times are GMT -5. The time now is 12:34 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup