2004 expedition speedometer and shifting problem - Ford Truck Enthusiasts Forums



2004 expedition speedometer and shifting problem

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-17-2014, 05:38 PM
dlsoc3 dlsoc3 is offline
New User
Thread Starter
 
Join Date: Aug 2014
Posts: 2
dlsoc3 is starting off with a positive reputation.
2004 expedition speedometer and shifting problem

I have a 2004 expedition with the 5.4l engine. The truck was built with 2003 parts however...it has the 4R70W transmission. The transmission failed and I replaced it with a junk yard transmission. After installing the new transmission my speedometer has stopped working and the truck will not shift past second gear. I removed the speed sensor from my original transmission and it still has not solved the problem. Does anyone have any insight to what may be happening? Cruise control will not light up on dash either.

Thank you
Reply With Quote
  #2  
Old 08-17-2014, 09:02 PM
Franklin2's Avatar
Franklin2 Franklin2 is offline
Moderator
 
Join Date: Jan 2001
Location: New Market, VA
Posts: 37,736
Franklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant futureFranklin2 has a brilliant future
Take it to autozone or someplace like that and get them to read the codes. If you still have a VSS error code, you need to figure out why.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Truck not shifting correctly, speedometer not working Southern Buckers 1994.5 - 1997 7.3L Power Stroke Diesel 68 10-02-2016 12:13 PM
2001 f 150 speedometer problems after rebuild Ebrown2469 1997 - 2003 F150 0 02-18-2016 02:33 PM
2004 expedition speedometer and shifting problem dlsoc3 Expedition & Navigator 1 08-18-2014 06:36 PM
4R75E transmission abyars111 Clutch, Transmission, Differential, Axle & Transfer Case 1 07-16-2014 02:19 PM
E4OD speedo issues kdennie1334 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 1 07-04-2014 09:55 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 12:32 AM.