injectors keep blowing the o ring off - Ford Truck Enthusiasts Forums



6.0L Power Stroke Diesel 2003 - 2007 F250, F350 pickup and F350+ Cab Chassis, 2003 - 2005 Excursion and 2003 - 2009 van

injectors keep blowing the o ring off

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-16-2014, 03:59 PM
Toyman's Avatar
Toyman Toyman is offline
Michigan Chapter Ldr
Thread Starter
 
Join Date: Feb 2004
Location: Wayland, MI
Posts: 11,287
Toyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputation
injectors keep blowing the o ring off

It's a 2006 F250 crew cab short box lariat. has had egr delete, studs, and gaskets. It now seems to be eating injectors. randomly they will just blow and it runs like crap. All of the injectors were replaced when the studs and gaskets were done. which is less that 10,000 miles ago.

Any ideas what could make this happen?
Reply With Quote
  #2  
Old 08-16-2014, 04:03 PM
bismic's Avatar
bismic bismic is online now
Post Fiend
 
Join Date: Nov 2003
Posts: 15,132
bismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputationbismic has a superb reputation
What injectors were installed (where did you get them)?

What is your fuel pressure?
Reply With Quote
  #3  
Old 08-16-2014, 06:50 PM
cheezit's Avatar
cheezit cheezit is offline
Post Fiend
 
Join Date: Oct 2009
Location: N. Fort Worth, tx
Posts: 12,115
cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.cheezit has a spectacular reputation.
Most common cause is not using a torque wrench. Over torqued will damage the hold down bolt, giving you the same issue as under torqued
Reply With Quote
  #4  
Old 08-16-2014, 06:55 PM
Rusty Axlerod's Avatar
Rusty Axlerod Rusty Axlerod is offline
Post Fiend
 
Join Date: Feb 2011
Location: L.A. (Lower Alabama)
Posts: 7,408
Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.Rusty Axlerod has a spectacular reputation.
Maybe tweaked injector hold down, or they didn't clean the oil out of the injector hold down bolt holes causing incorrect torque reading?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 injector issues tjustice 6.0L Power Stroke Diesel 19 01-10-2016 11:02 AM
Finally getting studded. mxer0022 6.0L Power Stroke Diesel 5 07-13-2014 11:15 PM
Entire Gasket Kit? AndeyHall 6.0L Power Stroke Diesel 27 03-07-2012 10:49 PM
Injector fuel oring blowing out twice hydrolocked domwri 6.0L Power Stroke Diesel 16 01-02-2012 01:33 PM
head studs without removing the head? 06stroke 6.0L Power Stroke Diesel 20 10-08-2008 03:06 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 01:06 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.