Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-08-2014, 04:08 PM
Henry Ford the 8th Henry Ford the 8th is offline
Freshman User
 
Join Date: Jul 2011
Posts: 36
Henry Ford the 8th is starting off with a positive reputation.
INFO display gone wacky

Of course I can call the dealer and leave the truck, but maybe somebody can tell me which button to push to fix this. The INFO display comes on at Key On with total mileage displayed (OK so far). I start the truck and the display indicates no trailer connected, brake controller value set to 6. I can vary the brake proportion value normally. Display stays on trailer info unless I shift into R; then it switches to "Rear Park Aid (On) Off" and the rear camera works, but when I shift to D the camera goes off but the display remains the same until I switch the Key Off. INFO, SETUP and RESET buttons have no effect. Anybody see this before?
Reply With Quote
Old 08-08-2014, 04:08 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 XLT backup camera vs 2014 celltech 2009+ F150 9 09-09-2014 06:38 AM
Wireless Backup Camera Rusty74 Super Duty & Heavy Duty 17 04-27-2014 03:15 PM
Keep blowing fuse #3 - 20amp - electrical dummy here sammie0126 Excursion - King of SUVs 1 11-04-2013 09:28 PM
Radio display MRB068 Explorer, Sport Trac, Mountaineer & Aviator 50 09-23-2013 02:40 PM
Outside Temp really an option 2LMAKER 2007+ Expedition & Navigator 2 03-25-2013 07:15 PM



All times are GMT -5. The time now is 06:52 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup