2007 Navigator Issue - Ford Truck Enthusiasts Forums

2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

2007 Navigator Issue

LinkBack Thread Tools Search this Thread
Old 08-03-2014, 07:03 PM
walleyealx walleyealx is offline
New User
Thread Starter
Join Date: Aug 2014
Posts: 4
walleyealx is starting off with a positive reputation.
2007 Navigator Issue

Just bought a 2007 Navigator w/ 105k on it. Took it on a 1000 mile trip with no problems. Afterwards I went up a hill and had to gas it a bit. When it reached 4-5k RPMs the check engine light started flashing and I felt like the engine started shuddering a bit and lost some power. After about 15 seconds the light went away and haven't had any issues since.

Took it to an autoparts store to get it scanned and there were no codes in the history. My first though it the spark plugs because of the mileage, but I was also thinking it could be the fuel filter because it did it at high RPMs. I guess I might just have to replace both.

Any thoughts?

Reply With Quote
Old 08-04-2014, 06:55 AM
RI-Matt's Avatar
RI-Matt RI-Matt is offline
Senior User
Join Date: Mar 2004
Posts: 370
RI-Matt is starting off with a positive reputation.
My guess would be a coil. As they start to go they can cause the engine to stutter especially at the higher RPMs when there is more load. I had this happen on my 06 F150 and it never threw a code, it would just cause the truck to shake and buck like riding a bull.

If the plugs have never been changed I would change them now anyway.

Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
2008 Ford F150 (Limited) SWAP with 2008 Lincoln Navigator GPS radio angeldiaz215 2004 - 2008 F150 2 03-24-2016 09:59 PM
hello dino2007 New Member Introductions 1 01-08-2016 01:39 PM
2005 Navigator won't start, running out of ideas. buddybar Expedition & Navigator 46 01-07-2016 08:26 AM
TRANS Acting up, help? xrsxtypes Expedition & Navigator 3 12-01-2015 09:50 AM
05 Navigator problems/questions JET-RO12 Expedition & Navigator 15 02-23-2014 07:25 PM

Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

All times are GMT -5. The time now is 02:03 AM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.