Truck not running right - Ford Truck Enthusiasts Forums



1994.5 - 1997 7.3L Power Stroke Diesel SPONSORED BY:

Truck not running right

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-01-2014, 11:01 PM
imjwm's Avatar
imjwm imjwm is offline
Junior User
Thread Starter
 
Join Date: Oct 2011
Location: Malta
Posts: 92
imjwm is starting off with a positive reputation.
Truck not running right

I am really trying to figure out what is wrong with my 95 Ford f250 7.3 diesel.
Drove the truck to work but when I left this evening soon after I started it it started to sputter and not run right so I shut out off and restarted it and it ran fine for a little bit but then started to do it more and more, now it does it right when I start it. It sounds like it is only running on a few cylinders! I first thought it might be out of fuel so I put more it still does it. any help will be much appreciated! Thanks
Reply With Quote
  #2  
Old 08-01-2014, 11:13 PM
madMatador78's Avatar
madMatador78 madMatador78 is offline
Postmaster
 
Join Date: Dec 2011
Location: Pecatonica, IL
Posts: 2,609
madMatador78 is gaining momentum as a positive member of FTE.
Sounds like it could be the valve cover harnesses. There are 2 per side. Check them carefully! They like to melt.
Reply With Quote
  #3  
Old 08-02-2014, 12:56 AM
Bob Cat Bob Cat is offline
Freshman User
 
Join Date: Apr 2014
Posts: 30
Bob Cat is starting off with a positive reputation.
Maybe the CPS sensor?
Reply With Quote
  #4  
Old 08-03-2014, 11:55 AM
imjwm's Avatar
imjwm imjwm is offline
Junior User
Thread Starter
 
Join Date: Oct 2011
Location: Malta
Posts: 92
imjwm is starting off with a positive reputation.
I think it is the connector that goes to the valve cover gasket, it is really melted!
Reply With Quote
  #5  
Old 08-03-2014, 11:34 PM
oldbird1965's Avatar
oldbird1965 oldbird1965 is online now
Post Fiend
 
Join Date: Aug 2004
Location: AZ
Posts: 17,410
oldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to behold
You found your problem!
Reply With Quote
  #6  
Old 08-04-2014, 09:45 AM
madMatador78's Avatar
madMatador78 madMatador78 is offline
Postmaster
 
Join Date: Dec 2011
Location: Pecatonica, IL
Posts: 2,609
madMatador78 is gaining momentum as a positive member of FTE.
^^^ X2, that be your issue. Not a bad job to do.
Reply With Quote
  #7  
Old 08-06-2014, 10:11 AM
imjwm's Avatar
imjwm imjwm is offline
Junior User
Thread Starter
 
Join Date: Oct 2011
Location: Malta
Posts: 92
imjwm is starting off with a positive reputation.
I thought I found the problem but I fixed that and it still does it! I pulled the valve cover and tested for power and it works fine but it still doesn't run right! What could it be now?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fuel treatments? Whats the best for Diesel d450heavy 6.0L Power Stroke Diesel 23 09-08-2013 06:32 PM
1988 F800 7.8L 474 turbo no fuel - air? brushwolf General Diesel Discussion 8 04-01-2013 07:36 PM
truck is running rough and shaking, not running on all cylinders? and shifting hard 4x4countryboy 1999 - 2003 7.3L Power Stroke Diesel 22 10-13-2011 09:58 PM
Deisel is driving me nuts with the chugging please help maddog9m 1999 - 2003 7.3L Power Stroke Diesel 17 12-14-2010 04:49 PM
Fuel gauge went out. Help Firemudder 6.0L Power Stroke Diesel 8 05-30-2010 08:28 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 05:11 PM.