Truck not running right - Ford Truck Enthusiasts Forums



1994.5 - 1997 7.3L Power Stroke Diesel SPONSORED BY:

Truck not running right

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-01-2014, 11:01 PM
imjwm's Avatar
imjwm imjwm is offline
Junior User
Thread Starter
 
Join Date: Oct 2011
Location: Malta
Posts: 92
imjwm is starting off with a positive reputation.
Truck not running right

I am really trying to figure out what is wrong with my 95 Ford f250 7.3 diesel.
Drove the truck to work but when I left this evening soon after I started it it started to sputter and not run right so I shut out off and restarted it and it ran fine for a little bit but then started to do it more and more, now it does it right when I start it. It sounds like it is only running on a few cylinders! I first thought it might be out of fuel so I put more it still does it. any help will be much appreciated! Thanks
Reply With Quote
  #2  
Old 08-01-2014, 11:13 PM
madMatador78's Avatar
madMatador78 madMatador78 is offline
Postmaster
 
Join Date: Dec 2011
Location: Pecatonica, IL
Posts: 2,596
madMatador78 is gaining momentum as a positive member of FTE.
Sounds like it could be the valve cover harnesses. There are 2 per side. Check them carefully! They like to melt.
Reply With Quote
  #3  
Old 08-02-2014, 12:56 AM
Bob Cat Bob Cat is offline
Freshman User
 
Join Date: Apr 2014
Posts: 30
Bob Cat is starting off with a positive reputation.
Maybe the CPS sensor?
Reply With Quote
  #4  
Old 08-03-2014, 11:55 AM
imjwm's Avatar
imjwm imjwm is offline
Junior User
Thread Starter
 
Join Date: Oct 2011
Location: Malta
Posts: 92
imjwm is starting off with a positive reputation.
I think it is the connector that goes to the valve cover gasket, it is really melted!
Reply With Quote
  #5  
Old 08-03-2014, 11:34 PM
oldbird1965's Avatar
oldbird1965 oldbird1965 is offline
Post Fiend
 
Join Date: Aug 2004
Location: AZ
Posts: 17,175
oldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to behold
You found your problem!
Reply With Quote
  #6  
Old 08-04-2014, 09:45 AM
madMatador78's Avatar
madMatador78 madMatador78 is offline
Postmaster
 
Join Date: Dec 2011
Location: Pecatonica, IL
Posts: 2,596
madMatador78 is gaining momentum as a positive member of FTE.
^^^ X2, that be your issue. Not a bad job to do.
Reply With Quote
  #7  
Old 08-06-2014, 10:11 AM
imjwm's Avatar
imjwm imjwm is offline
Junior User
Thread Starter
 
Join Date: Oct 2011
Location: Malta
Posts: 92
imjwm is starting off with a positive reputation.
I thought I found the problem but I fixed that and it still does it! I pulled the valve cover and tested for power and it works fine but it still doesn't run right! What could it be now?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Starting issues nut_wrinkle Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 19 06-29-2016 01:22 AM
Can heat soak be intermittent? Maybe it's something else? EYEDEYE Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 23 09-26-2015 02:42 PM
Hesitation, Skipping at Low RPM's (long) Swanolck 1999 - 2003 7.3L Power Stroke Diesel 44 06-03-2015 10:10 AM
Injector pump ?, think I need one. Realslowww Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 19 03-26-2015 09:45 PM
Fuel pump problem????? Maybe? ttrammell2002 1987 - 1996 F150 & Larger F-Series Trucks 5 07-23-2014 09:54 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 06:47 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.