V10 running rough - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V10 (6.8l)
Log In 


Modular V10 (6.8l) SPONSORED BY:

V10 running rough

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-30-2014, 10:48 AM
DetailerDave's Avatar
DetailerDave DetailerDave is offline
Elder User
 
Join Date: May 2004
Location: Wilm, De
Posts: 689
DetailerDave is starting off with a positive reputation.
V10 running rough

After some repair work, my truck is running rough at times. High gear (OD) 55 mph or so, 1500 rpms, light throttle to accelerate, it feels like the engine wants to jump out from under the hood. Downshift, 2500 rpms, it is smooth as silk. I had the intake off, to replace the heater pipe underneath. When putting back together, I noticed the supply vacuum line to the EVR was broken. I repaired it, and my assistant insstalled the vac lines, fuel lines, etc. It was almost imposssible to see what you are doing, and I suspect my helper may not have put things back together correctly. The truck runs good in general, plenty power upon taking off from a light, etc, only when in high gear, low rpm, light throttle situation. I have tried to look at the vac connections, and it is impossible to see. Mirrors, lights, all to no avail. This weekend, I will try to perform a vac test on the lines, or else take parts back off to be able to see the EVR vac connections. Any other ideas are appreciated.
__________________
99 F250 SD SuperCab 4x4 V10
95 Mustang Coupe V6
Reply With Quote
  #2  
Old 08-25-2014, 10:08 AM
TIUSER's Avatar
TIUSER TIUSER is offline
Senior User
 
Join Date: Dec 2013
Location: S.E. MI
Posts: 143
TIUSER has a good reputation on FTE.TIUSER has a good reputation on FTE.
First I would suggest COPs. I am having the same problem right now, and mine has no compression in cylinder #5. Looking like it is valve and/or spring issue but again we are still working on mine. Hopefully you have the better luck than I have.
__________________

2002 Excursion Limited Ultimate, V10, 4WD
5-STAR TUNED, REDHEAD, CaryT's V/MODIFIED B, Bilstein 5100s, 2" front hangers, 3.5" rear blocks, Adjustable Track bar, 30mm Rear sway bar, Single 5100 steering stabilizer, 04 Harley wheels w/ 295/70/18s
Reply With Quote
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Major idle problem Brian Ski 44 1987 - 1996 F150 & Larger F-Series Trucks 2 08-25-2015 08:54 PM
timing question saauvenshine 1948 - 1956 F1, F100 & Larger F-Series Trucks 8 04-07-2015 09:56 AM
EVR valve ltyler179 1987 - 1996 F150 & Larger F-Series Trucks 9 01-04-2015 10:55 AM
Rough Running V10 DetailerDave Super Duty & Heavy Duty 6 08-03-2014 08:15 PM
P 401 CODE INSUFFICIENT EXHAUST GAS RECIRCULATION FLOW richdavis69 1987 - 1996 F150 & Larger F-Series Trucks 8 11-13-2012 07:07 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V10 (6.8l)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 04:41 PM.

 

Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup