Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.4L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-23-2014, 05:33 PM
themaniam1 themaniam1 is offline
New User
 
Join Date: Jul 2013
Posts: 5
themaniam1 is starting off with a positive reputation.
Air whistle / leak from turbo?

Fairly new to Diesels and especially turbos but have enough mechanic knowledge to come close to a problem. So I have a 2008 F-450, engine was replaced just before I bought it with a factory crate engine. It has 13,000 on it and is still under the 3 yr engine warranty.

Problem: When the boost starts, it make a sound like an air compressor leak and gets louder until about 10 psi boost and then starts to whistle. The whistling just gets louder and higher pitched as the boost goes up. It sounds like a fire truck if is vary the throttle. If I let off the throttle and let the boost drop below 10 then the whistle stops. If I gently accelerate I can keep it from whistling but still get the air leak sound. Any ideas? Do I take it to a dealer?
Reply With Quote
  #2  
Old 07-23-2014, 05:55 PM
sxrfun sxrfun is offline
Freshman User
 
Join Date: Mar 2011
Posts: 35
sxrfun is starting off with a positive reputation.
Check all your intercooler boots and clamps and make sure they are tight. Also check where the intake mounts on to the turbo and make sure all intake clamps are tight as well.
Reply With Quote
  #3  
Old 07-23-2014, 06:05 PM
JWC 3's Avatar
JWC 3 JWC 3 is offline
Post Fiend
 
Join Date: Dec 2012
Location: Tennessee
Posts: 5,968
JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.
Also check for missing, broken exaust manifold bolts . Just had a 550 with a high pitch whistle . It was a broken manifold bolt .
__________________
78 F100 ,Daily driver . Life will test you . Never give up ....
Reply With Quote
  #4  
Old 07-23-2014, 09:03 PM
themaniam1 themaniam1 is offline
New User
 
Join Date: Jul 2013
Posts: 5
themaniam1 is starting off with a positive reputation.
You guys are awesome. Found the leak. It was the lower down pipe boot right in the front of the truck where it connects to the bottom of the intercooler. Now I just have to find a parts store that has one or go to the dealer in the morning.

Thank you for your help.
Reply With Quote
  #5  
Old 07-24-2014, 08:49 AM
sxrfun sxrfun is offline
Freshman User
 
Join Date: Mar 2011
Posts: 35
sxrfun is starting off with a positive reputation.
When you put new boot on make sure to clean where it mounts on intercooler and hot side pipe with brake cleaner to make sure there's no oil residue. Also when you put it together...spray some hair spray on parts that go together...it'll act as glue and help keep it from popping off under higher boost numbers.
Reply With Quote
  #6  
Old 07-24-2014, 09:30 AM
themaniam1 themaniam1 is offline
New User
 
Join Date: Jul 2013
Posts: 5
themaniam1 is starting off with a positive reputation.
Will do. I am about to drive to the dealer to get the part. Thank you for timely advise.
Reply With Quote
  #7  
Old 07-26-2014, 11:07 PM
themaniam1 themaniam1 is offline
New User
 
Join Date: Jul 2013
Posts: 5
themaniam1 is starting off with a positive reputation.
Update. Installed new boot, $65 from the dealer, and it drives quite (normal sound) and has power again. Towed the boat to the lake and all is well.
Reply With Quote
Old 07-26-2014, 11:07 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.4L Power Stroke Diesel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
whistle from blower motor bunky383 2007+ Expedition & Navigator 0 04-09-2014 12:09 AM
No turbo at idle Andrews6.0 Super Duty & Heavy Duty 2 01-30-2014 08:52 AM
high pitch whistle BRay09 6.0L Power Stroke Diesel 17 11-26-2013 08:17 AM
Whistle when letting up on accelerator JJKK 6.4L Power Stroke Diesel 11 09-17-2013 04:13 PM
What's this whistle sound? 19687.3idi 1999 - 2003 7.3L Power Stroke Diesel 2 05-18-2013 08:13 AM



All times are GMT -5. The time now is 05:01 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup