Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V10 (6.8l)
Sign in using an external account
Register Forgot Password?


Modular V10 (6.8l) SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-18-2014, 11:18 PM
buddy26 buddy26 is offline
New User
 
Join Date: Jul 2014
Posts: 3
buddy26 is starting off with a positive reputation.
O6 f250 horn not working

The horn is not working I changed the fuse for the horn and still don't work. The cruise control still works and the air bag light is not on. I can here the relay making a clicking noise when you push the horn just no sound. Does it sound like the horn is gone bad or could it be the relay? Thanks
Reply With Quote
  #2  
Old 07-19-2014, 11:33 AM
Hank85713 Hank85713 is offline
Posting Guru
 
Join Date: Feb 2002
Location: Tucson USA
Posts: 1,605
Hank85713 is gaining momentum as a positive member of FTE.
Check the connections AT the horn itself, they may have corroded, come loose. It is also possible that you have a bad relay, or tha the hot wire to the horn has corroded, broken as I noted above.
Reply With Quote
  #3  
Old 07-20-2014, 06:05 AM
JWA's Avatar
JWA JWA is offline
Post Fiend
 
Join Date: Aug 2010
Location: Reynoldsburg, Ohio
Posts: 7,003
JWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputation
Run a wire directly from the battery to the horn itself, touching the input tab---if it works you have an electrical path issue. If it doesn't then its the horn itself.

If its a path problem I'd suspect the relay contacts. Since it would be supposedly operating the lack of current to the horn suggests the contacts inside the relay housing.
Reply With Quote
  #4  
Old 07-20-2014, 10:10 AM
buddy26 buddy26 is offline
New User
 
Join Date: Jul 2014
Posts: 3
buddy26 is starting off with a positive reputation.
Thanks I will try everything that was mentioned and see what happens and report back
Reply With Quote
  #5  
Old 08-22-2014, 12:05 AM
buddy26 buddy26 is offline
New User
 
Join Date: Jul 2014
Posts: 3
buddy26 is starting off with a positive reputation.
Finally had time to take apart and check everything it was the horns themselves. Replace horns with a bad boy horn and everything works now. Thanks
Reply With Quote
Old 08-22-2014, 12:05 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Good power but horns won't honk Velocity2 1967 - 1972 F-100 & Larger F-Series Trucks 11 11-27-2014 03:49 PM
94 F150 horn not working 1994 f150 4x4 1987 - 1996 F150 & Larger F-Series Trucks 2 03-22-2013 10:04 AM
Horn Probelms on 1989 Full Size Bronco jdmak68 1978 - 1996 Big Bronco 2 12-13-2007 10:09 AM
98 Explorer horn oskie Explorer, Sport Trac, Mountaineer & Aviator 4 01-27-2006 01:38 AM
1969 f100 horn/brake light screwup jimbo_1 1967 - 1972 F-100 & Larger F-Series Trucks 8 06-07-2000 05:46 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V10 (6.8l)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 06:33 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup