03 explorer issues, Help! - Ford Truck Enthusiasts Forums



03 explorer issues, Help!

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-15-2014, 03:17 PM
Joel1984 Joel1984 is offline
New User
Thread Starter
 
Join Date: Jul 2014
Posts: 1
Joel1984 is starting off with a positive reputation.
03 explorer issues, Help!

Hi folks,

I have an 03 explorer, V8 Eddie Bauer. It's had a rough idle for a little while and the other day my check engine light flashed at me. Looked up the codes and it told me I had a couple cylinders misfire and a couple codes saying "system too lean" bank 1 and 2.
I'm certainly no professional but i always like to give it a go when I think I can manage.

So yesterday I took out the MAF sensor and cleaned it, changed the air filter, and changed out my spark plugs to start. (Spark plugs were due to be replaced)
I started her up again and she sounded much better. Went for a quick spin and it seemed like the troubles were gone. Sat inside in the driveway for a few minutes and the idle got progressively worse. Opened the hood and had a look and after a few minutes it just died.
Started it up again and it died a few minutes later.
It starts up fine and drives fine but the idle is rough and dies out after a bit.
So this morning it wouldn't even start. Battery is fine, it still turns everything on, but I turn the key and it just makes one click noise and doesn't do anything.
Any ideas??
Much appreciated!
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wont Idle Furr308 1997-2006 Expedition & Navigator 4 01-13-2016 09:08 PM
03 Exped service engine soon light after spark plug change i.gon 1997-2006 Expedition & Navigator 6 01-08-2016 09:44 AM
Issue with Fuel/Starting..*Frustrating* JW1971 1978 - 1996 Big Bronco 6 11-20-2014 12:09 AM
Erratic / Jumping idle resq302 Explorer, Sport Trac, Mountaineer & Aviator 3 10-25-2014 11:06 AM
AC problem driving me nuts dickdowning Cooling, Heating, Ventilation & A/C 1 11-11-2007 10:58 AM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 10:46 AM.