7.3 Bad injector - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Diesel > 1994.5 - 1997 7.3L Power Stroke Diesel
Log In 


1994.5 - 1997 7.3L Power Stroke Diesel SPONSORED BY:

7.3 Bad injector

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-08-2014, 05:46 PM
Smokey_7.3 Smokey_7.3 is offline
Junior User
 
Join Date: Jun 2013
Posts: 70
Smokey_7.3 is starting off with a positive reputation.
7.3 Bad injector

You guys are awesome! I can't thank yall enough for the help I've received here.

But onto the next challenge!!!!

My 96 7.3l has a dead cylinder. Scanner says cylinder 5. What all is required and is there a good write up on how to replace the injector myself?
Reply With Quote
  #2  
Old 07-08-2014, 08:46 PM
ReBilld's Avatar
ReBilld ReBilld is offline
Post Fiend
 
Join Date: Jan 2012
Location: Southern West Virginia
Posts: 9,614
ReBilld has a great reputation on FTE.ReBilld has a great reputation on FTE.ReBilld has a great reputation on FTE.ReBilld has a great reputation on FTE.ReBilld has a great reputation on FTE.
May not be the injector. Could be the wiring to that injector. Check the plug on the valve cover gasket for burnt pins.
__________________
Bill

'95 F350 CCLB 4x4 dually,ZF 5spd,4.10,Rosewood Stage 2s,T500,S366,IC,Tony Wildman tunes,e-fuel,6637,CCV mod,3.5" DP,Diamond Eye 5" exhaust,Valair clutch,IH water pump,Scangauge,GlowShift gauges
'92 F150 RCLB 4x4, 4.9 6cyl., 5 spd., daily beater
Reply With Quote
  #3  
Old 07-08-2014, 10:25 PM
Smokey_7.3 Smokey_7.3 is offline
Junior User
 
Join Date: Jun 2013
Posts: 70
Smokey_7.3 is starting off with a positive reputation.
Well I have a set of 8 OEM injectors and a different gasket I have laying around. Took me a little while to figure out how it all came our but it's done.
She's still puffing like a chain smoker but runs smoother.
Reply With Quote
  #4  
Old 07-08-2014, 11:27 PM
MOOSE_MACHINE's Avatar
MOOSE_MACHINE MOOSE_MACHINE is offline
Postmaster
 
Join Date: Mar 2004
Posts: 2,855
MOOSE_MACHINE is gaining momentum as a positive member of FTE.MOOSE_MACHINE is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by Smokey_7.3 View Post
Well I have a set of 8 OEM injectors and a different gasket I have laying around. Took me a little while to figure out how it all came our but it's done. She's still puffing like a chain smoker but runs smoother.
Puffing what color. I'm assuming you pulled the injectors but did you replace the orings.
__________________
Sometimes your the windshield, sometimes your the bug
1997 F-350 xlt cclb PSD 4x4 zf5, 160/80's, custom tunes, T500, DIY e-fuel, 6.0 i/c, 38R, 3" plenums, gauges, 4" turbo back exhaust, diy bellows, south bend clutch
1992 F-250 2wd eclb 5.8 farm truck
1989 F-350 4x4 7.3 c6 auto retiread
Nick
Reply With Quote
  #5  
Old 07-08-2014, 11:43 PM
Smokey_7.3 Smokey_7.3 is offline
Junior User
 
Join Date: Jun 2013
Posts: 70
Smokey_7.3 is starting off with a positive reputation.
Blue.

Yes I did replace the orings on that 1 injector I replaced. I didn't swap all 8.
Reply With Quote
  #6  
Old 07-09-2014, 07:49 AM
oldbird1965's Avatar
oldbird1965 oldbird1965 is offline
Post Fiend
 
Join Date: Aug 2004
Location: AZ
Posts: 14,485
oldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to beholdoldbird1965 is a splendid one to behold
Blue should disappear, its probably oil left over in the cylinders from the injector being changed out.
__________________
Glenn The Mule-96 2WD F250 EC/LB auto PSD
The old gray Mare 97 dually cc,modified s366 turbo,stage II's,DI IC,studs,springs,rods,JW auto,4:10 LS,air bags,SD uvch,efuel,FS2500 bypass oil filter,HVHF IDM,IH WP,6.0 trans cooler & rad fan,MBRP 4",SD tensioner,AFE air filter,220 amp alt,38 gal rear tank & 33 gal aux bed tank,aux oil cooler,soundproofed,4 tuners on Hydra,ac cold mod,XS batteries,riffraff hpop reservoir,aluminum radiator,Adrenaline hpop, water injection
Reply With Quote
  #7  
Old 08-22-2014, 03:58 PM
Smokey_7.3 Smokey_7.3 is offline
Junior User
 
Join Date: Jun 2013
Posts: 70
Smokey_7.3 is starting off with a positive reputation.
Turns out it was a bent connecting rod. Replaced and smoke went away. Thanks you guy!
Reply With Quote
Old 08-22-2014, 03:58 PM
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
7.3L injector/IDM issues Jsamsonite 1999 - 2003 7.3L Power Stroke Diesel 9 05-16-2015 10:30 AM
'88 7.3 hard starting, injectors? pjcat Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 10 04-15-2015 02:21 AM
7.3 miss alan szynkowski 1999 - 2003 7.3L Power Stroke Diesel 1 11-26-2014 11:26 AM
Injectors??? Matthewv87 1999 - 2003 7.3L Power Stroke Diesel 24 04-06-2014 08:58 AM
injector question DUSTYNUTS44 Super Duty & Heavy Duty 0 11-27-2013 07:23 PM


Go Back   Ford Truck Enthusiasts Forums > Diesel > 1994.5 - 1997 7.3L Power Stroke Diesel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 08:43 AM.

 

Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup