Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-05-2014, 03:12 PM
SlickWilly001 SlickWilly001 is offline
New User
 
Join Date: Jul 2014
Posts: 1
SlickWilly001 is starting off with a positive reputation.
1999 5.4 4x4 runs rough between 1200 & 1500 rpm

Truck runs great until I am cruising at 1200 to 1500 rpm's. Acts like it has a high performance cam (doesn't want to accelerate smoothly like the rest of the power band). Kind of acts like its starving for fuel....or air. Not sure which! Check engine light is NOT lit. Thanks for any input.
Reply With Quote
  #2  
Old 07-06-2014, 07:54 PM
carguy94 carguy94 is offline
Senior User
 
Join Date: Mar 2014
Location: southern maryland
Posts: 337
carguy94 is starting off with a positive reputation.
get any trouble codes pulled a trouble code will be set before a MIL will usually. any recent repair history tune up. is this the original drive train power train to the truck. how is the idle temperature and gauges.
Reply With Quote
Old 07-06-2014, 07:54 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
92 7.3l idles great won't go past 1200 rpm ihf-350 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 10 06-06-2014 10:47 AM
1995 f150 acting wierd at start up? cjben 1987 - 1996 F150 & Larger F-Series Trucks 10 04-17-2008 09:26 PM
RPM Flux lowcountry 2004 - 2008 F150 4 04-29-2007 12:17 PM
Ignition Problem or ? 460Gene Big Block V8 - 385 Series (6.1/370, 7.0/429, 7.5/460) 3 07-09-2002 11:35 AM
eec codes mavman 1987 - 1996 F150 & Larger F-Series Trucks 9 11-03-2001 09:15 PM



All times are GMT -5. The time now is 11:22 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup