P0720 Code on 2003 Excursion 6.8 V10 - Page 2 - Ford Truck Enthusiasts Forums



P0720 Code on 2003 Excursion 6.8 V10

Reply
 
 
 
Thread Tools Search this Thread
  #16  
Old 08-25-2014, 09:37 PM
Paul T Paul T is offline
Elder User
Thread Starter
 
Join Date: Apr 2008
Location: Cottageville, WV
Posts: 634
Paul T is gaining momentum as a positive member of FTE.
Update: I changed the #6 coil and all seems to be fixed. I took it on a 6 mile trip and all seems well. No stalling, missing, or dieing and no codes. I will post again if it is not fixed. Thanks for the help everyone!
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2005 Expedition 5.4 - Rough Idle htodac Modular V8 (4.6L, 5.4L) 2 12-29-2016 01:25 PM
P0171/P0174 Epic-Knightmare 1997 - 2003 F150 8 06-12-2016 03:07 PM
5.4L Triton Running Rich blaster4d 1997-2006 Expedition & Navigator 3 12-26-2014 04:02 AM
05 Expedition P0430 Catalyst System Efficiency Below Threshold (Bank 2) WhyFord 1997-2006 Expedition & Navigator 35 07-06-2014 03:30 PM
New scan tool, uncertain on results. NovaNewfie 1997 - 2003 F150 7 04-13-2014 02:34 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 11:14 PM.