460 efi question - Ford Truck Enthusiasts Forums

460 efi question

LinkBack Thread Tools Search this Thread
Old 06-25-2014, 01:16 AM
Dmedlicott1 Dmedlicott1 is offline
New User
Thread Starter
Join Date: Jun 2014
Posts: 1
Dmedlicott1 is starting off with a positive reputation.
460 efi question

Hello I recently got a 97 f250 5 speed 460 to pull my camper. Ran good the first while but now has little to no power. Can really notice it in the higher rpm when the motor has warmed up. Any help to get me going in the right direction would be appreciated. Thanks!
Reply With Quote
Old 06-25-2014, 09:30 PM
eakermeld's Avatar
eakermeld eakermeld is offline
Posting Guru
Join Date: Nov 2013
Location: South Central,MO
Posts: 2,109
eakermeld is gaining momentum as a positive member of FTE.eakermeld is gaining momentum as a positive member of FTE.
Start by checking the fuel pressure. Sounds like you have either a failing fuel pump, stopped up filter, or a failing pressure regulator. If everything there is ok, O2 sensor would be my next suspect. Go ahead and pull codes to see what the truck has to say about it.
Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
460 the king of ford engines ironman1977 Big Block V8 - 385 Series (6.1/370, 7.0/429, 7.5/460) 57 04-19-2016 02:47 PM
Ford Racing Wires too Long for 460 EFI? GuitarJesus 1987 - 1996 F150 & Larger F-Series Trucks 0 11-14-2015 06:56 PM
1977 460 retarded timing set and factory emissions Crewcabber Big Block V8 - 385 Series (6.1/370, 7.0/429, 7.5/460) 2 05-30-2015 05:53 PM
What's a better gasket for a water pump 460? Highboy74 1973 - 1979 F-100 & Larger F-Series Trucks 4 04-19-2015 03:49 PM
has anyone put a 460 into an old F5 007brian 1948 - 1956 F1, F100 & Larger F-Series Trucks 9 03-02-2015 08:29 AM

Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

All times are GMT -5. The time now is 07:23 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.