Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-12-2014, 01:10 AM
ecyrbh ecyrbh is offline
Senior User
 
Join Date: Aug 2011
Posts: 106
ecyrbh is starting off with a positive reputation.
RSC icon on at random times....help

I have an 08 Expy EB 2wd and a month or so ago the RSC icon lit up on the dash for no apparent reason while driving on the highway at approx. 70-75 mph(in overdrive)...I tried to turn off the light by pressing the switch,but the light would not go away.The only way I got it to go out was to turn the vehicle off and restart it...Well,it happened to me again 3 times this week on a long trip while towing my travel trailer..It would come on randomly,and again was unable to control the light with the switch...The conditions that I was driving were 75-80 mph,up and down steep grades,in gusty crosswinds and headwinds as well,bearing in mind at times uphill speeds were significantly reduced to anywhere from 45-55 mph.All of the towing that I was doing was in manual 5th gear(on uphill grades) and in overdrive when able to on flat ground...I never noticed any reduction in performance or braking the entire time...Are there any common issues with the RSC system or could it just be the driving conditions I was experiencing???...Help
Reply With Quote
  #2  
Old 06-12-2014, 09:30 PM
montecarlo31 montecarlo31 is offline
Elder User
 
Join Date: Sep 2004
Posts: 547
montecarlo31 is starting off with a positive reputation.
Check your steering position sensor. That's a common issues.
Reply With Quote
  #3  
Old 06-12-2014, 10:53 PM
ecyrbh ecyrbh is offline
Senior User
 
Join Date: Aug 2011
Posts: 106
ecyrbh is starting off with a positive reputation.
Would having this icon appear set a fault code for me to access with a scan tool????
Reply With Quote
  #4  
Old 06-13-2014, 11:39 AM
pdqford pdqford is offline
Posting Guru
 
Join Date: Jan 2001
Location: Central NYS
Posts: 1,853
pdqford is gaining momentum as a positive member of FTE.pdqford is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by montecarlo31 View Post
Check your steering position sensor. That's a common issues.
Especially if you have had the front end aligned and they didn't check/reset the SAS.
__________________
Jim in Central NY
'79 2WD F-150 Lariet w/302,4spd OD, 228,965 mi. (Original Owner!)
'02 4X4 Navigator w/5.4L DOHC 32v Intech V-8 (VIN R).
Reply With Quote
  #5  
Old 06-13-2014, 11:59 AM
ecyrbh ecyrbh is offline
Senior User
 
Join Date: Aug 2011
Posts: 106
ecyrbh is starting off with a positive reputation.
Nope,..haven't had the front end aligned...
Reply With Quote
  #6  
Old 06-13-2014, 10:14 PM
montecarlo31 montecarlo31 is offline
Elder User
 
Join Date: Sep 2004
Posts: 547
montecarlo31 is starting off with a positive reputation.
Quote:
Originally Posted by pdqford View Post
Especially if you have had the front end aligned and they didn't check/reset the SAS.
Never had that issue and we do frequent alignments. I'm betting it's the sensor in the steering column.
Reply With Quote
  #7  
Old 06-14-2014, 12:14 PM
ecyrbh ecyrbh is offline
Senior User
 
Join Date: Aug 2011
Posts: 106
ecyrbh is starting off with a positive reputation.
Well I'm gonna have to look into the steering sensor,but still confused as to why I couldn't shut the light off by cycling the RSC switch on and off....
Reply With Quote
Old 06-14-2014, 12:14 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Explorer - RSC Issue LashLaRue Explorer, Sport Trac, Mountaineer & Aviator 1 01-01-2014 03:33 PM
superduty E-350 problem with the RSC 6t56 Super Duty & Heavy Duty 0 12-30-2009 10:56 AM
ABS RSC Warning Light Power Stroke 7107 Explorer, Sport Trac, Mountaineer & Aviator 2 09-14-2009 07:22 AM
RSC Alarm going off! need help. Blowinsmoke 1968-2013 Full Size Vans 3 09-04-2009 10:23 PM
Advancetrac is going to KILL me! rbarbot2 2007 - 2014 Expedition & Navigator 19 01-18-2008 12:56 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup