Oil on MAF sensor (05 Navigator) - Ford Truck Enthusiasts Forums



Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator

Oil on MAF sensor (05 Navigator)

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-02-2014, 10:47 PM
TheACN TheACN is offline
Junior User
Thread Starter
 
Join Date: Jan 2013
Posts: 64
TheACN is starting off with a positive reputation.
Oil on MAF sensor (05 Navigator)

Hey all,

I have an 05 Navigator. I had some rough idle issues, like on one red light engine would idle a little rough (RPM is fine though) and after few miles of driving on another red light engine would idle just fine. So I thought cleaning MAF sensor might help solve the issue. Long story short; I pulled the sensor out and noticed it had some oil around it. I've uploaded a video on YouTube showing where the oil is. Also, I've taken some pictures of the filter. I also noticed a oil-like stain on the polyester part of the filter.

Did anyone had a similar issue before? I have no idea why/how oil might reach that height. My initial thought was faulty PCV sensor, but AFAIK this engine does not have one (it's different than 03-04's, which has the PCV hose on the passenger side of the engine).

Any idea is appreciated.


Edit: Filter is like 3000 miles old


MAF Sensor:

Filter & Sensor location:






Last edited by TheACN; 06-03-2014 at 12:30 AM. Reason: Extra info
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1990 F350 build Nero Morg 1987 - 1996 F150 & Larger F-Series Trucks 10 10-15-2016 08:19 PM
Someone knows that model? JeanFabricio 1948 - 1956 F1, F100 & Larger F-Series Trucks 16 01-09-2016 06:51 AM
Steering Arm - Should I pay any attention to it? While I'm here... johnson.jeff.a 1948 - 1956 F1, F100 & Larger F-Series Trucks 25 11-17-2015 07:14 PM
Harriet Rides Again... sort of quinletc 1967 - 1972 F-100 & Larger F-Series Trucks 2 08-30-2015 03:37 AM
Air compressor Willz74 1973 - 1979 F-100 & Larger F-Series Trucks 14 07-31-2015 11:54 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 11:17 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.