Help! Fuse 13... - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1987 - 1996 F150 & Larger F-Series Trucks
Log In 


1987 - 1996 F150 & Larger F-Series Trucks 1987 - 1996 Ford F-150, F-250, F-350 and larger pickups - including the 1997 heavy-duty F250/F350+ trucks

Help! Fuse 13...

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-13-2014, 09:35 AM
77_F150_4x4 77_F150_4x4 is offline
Elder User
 
Join Date: Feb 2000
Location: Temperance,MI
Posts: 748
77_F150_4x4 is gaining momentum as a positive member of FTE.
Help! Fuse 13...

Here we go, 96 F150 X cab 351w 4x4...

Last night on my way home ABS light started flashing...code 16, found out bad ABS module code.

This morning I didn't even remember it, hit the remote start finished getting ready, jumped in the truck key on foot to brake pedal, shifter, foot off brake back on, repeat multiple times phone call to work, ford failure. I will hear about this one.

Code 16 ABS, didn't scan it just watched the old flashes. Pulled fuse cover off started checking fuses. Fuse 13 cooked, R&R BAAM junk. So fuse 13 controls;
ABS, unhooked module and hydraulic controller on frame
Brake interlock, never had to deal with one but it worked fine always.
EEC, truck runs...even with blown fuse
Cruise control, unhooked
Stop/hazard lamps, pulled LED bulbs(maybe)
Stop sense for EEC, unhooked BOO switch.

After all of that still would cook a fuse, even unhooked jumper harness for cruise control(switch is dry in master). So pulled driver kick panel cover check ground bright and shiny with its green coated bolt. I finally got somewhere when I pulled column cover screws and pulled ignition switch out it tripped the 4ways, put a fuse back in and it did not blow.

I have never seen a multifunction switch go bad on these trucks, I put the ignition switch back in shut it off started hooking one thing up at a time, and check fuse didn't blow, fire the truck up no more code 16 from ABS light.

Pulled multifunction switch off wiring to it is not chaffed or bare, everything wiring aspect looks great( I hate rust, I hate corrosion I try to stay ahead of it). The switch itself on tear down looks to be fine, put it back together, put it back on, I never noticed before but if the door is open with 4ways on it will flash and chime the warning chime twice pause then chime twice? is that normal? any other ideas? it won't blow the fuse now but I don't want to go through this again.

Help!
Thank you,
Curtis
__________________
96 F150 4x4 Xcab short bed 351W/E4OD Eclipse Package- project 400 OBD-II E4OD, 3/4ton parts
Reply With Quote
  #2  
Old 05-13-2014, 01:29 PM
dixie460's Avatar
dixie460 dixie460 is offline
Postmaster
 
Join Date: Nov 2011
Location: SW Florida
Posts: 2,842
dixie460 has a good reputation on FTE.dixie460 has a good reputation on FTE.dixie460 has a good reputation on FTE.
Sounds like the multifunction switch is failing. I got in my truck one day and as I hit the starter I saw a thin little trail of smoke coming from the MFS. Took it all apart and cleaned up the insides. Stupid things... they shoulda just kept the high/low switch on the floor and the wiper controls on the dash.

I wouldn't worry about the chime thing, and you're probably ok since you cleaned the internals up. I wouldn't expect it to fail again anytime soon.

Oh and if that ever happens to you again where you can't get out of park (another useless feature, there are parking brakes for a reason) all you have to do is turn the key one notch forward, like halfway to Run, and that will mechanically disable the shifter interlock feature and let you shift to neutral. Then you can start the truck and go from there
__________________
96 F-150 SCSB 351 Auto 4x4 - MileMarker hubs - 31x10.50s - 130A Alternator - Badlands 12K Winch - Onboard Air - Thrush Glasspacks - Full LED Conversion - Hydroboost Conversion - RioRand 18W Floodlights
Quote:
Originally Posted by Ghosteh View Post
Hacksaws, glass packs, drill pipe, railroad rails...
There's so much fail in this thread that I don't even know where to start.
Reply With Quote
  #3  
Old 05-13-2014, 01:36 PM
RIKIL's Avatar
RIKIL RIKIL is offline
Posting Guru
 
Join Date: Sep 2008
Posts: 2,074
RIKIL has a great reputation on FTE.RIKIL has a great reputation on FTE.RIKIL has a great reputation on FTE.RIKIL has a great reputation on FTE.RIKIL has a great reputation on FTE.RIKIL has a great reputation on FTE.
I had this fuse blow on me every time I used my turn signal. Turned out that one of my brake/tail lights was bad...just something to keep in mind.
__________________
RIKIL
--------------
Red, 1992 F150, 351W, E4OD, Vortech V-2 Si trim blower, Snow Performance water/meth injection system, custom cam, Edelbrock Performer intake, Twisted Wedge 205cc heads, shorty full-length headers, MASS Air (converted), tuning with QuarterhorseRT, 4x4, short bed, 33" tires
Reply With Quote
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS Light - Code C1096 - Fix JustFixIt Expedition & Navigator 3 08-05-2015 04:21 PM
no brake lights mike L Electrical Systems/Wiring 5 03-19-2015 07:41 PM
96 bronco fuse #13 15 amp Diablo540 1978 - 1996 Big Bronco 14 07-27-2014 11:02 PM
Ford Expedition 2001 Battery Drain Fuse #15, #14, GEM expeditionph Expedition & Navigator 11 04-24-2013 11:34 AM
ABS Flashing, Brake Blows fuse Eda Super Duty & Heavy Duty 10 09-15-2012 12:09 PM


Go Back   Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1987 - 1996 F150 & Larger F-Series Trucks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 05:14 PM.

 

Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup