Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty
Sign in using an external account
Register Forgot Password?


Super Duty & Heavy Duty 1999 to current Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-20-2014, 10:55 PM
af11 af11 is offline
New User
 
Join Date: Jan 2011
Posts: 8
af11 is starting off with a positive reputation.
03 6.0 rough idle issue

I just got an 03 6.0 and a few days ago it developed a rough idle, it takes a little longer to crank and idles fine for 30 seconds to a minute then the rough idle kicks in also I noticed when I drive it the low rpm range is a little choppy and when I come to a stop it goes a little below idle then resumes the rough idle issue. I had it die on the road a day prior to this after it lost complete power at a red light, it started to idle low so I tried to counteract with a little throttle and with the throttle all the way it did nothing, a few minutes it died on the road and took a few minutes to start back up I did a set of filters and it hasn't done it again but I still have the rough idle, I checked the icp sensor and wiring no oil so I cleaned it up a bit and it runs a little smoother but want to know if anyone might have any other suggestions.
Reply With Quote
  #2  
Old 04-20-2014, 11:05 PM
89stinger's Avatar
89stinger 89stinger is offline
Senior User
 
Join Date: Dec 2007
Location: Gilbert, AZ
Posts: 127
89stinger is starting off with a positive reputation.
Hi af11. My 03 6.0 did the same thing.... the first time it was the icp sensor. Second time it was the HPOP. The third time it did it it was the FICM. ICP sensor doesn't have to leak to be bad. Just my 2 cents
__________________
2003 F-250 6.0 PSD Crew Cab LB 6" ProComp lift Lund Moon Visor
2012 Edge

Reply With Quote
  #3  
Old 04-20-2014, 11:38 PM
af11 af11 is offline
New User
 
Join Date: Jan 2011
Posts: 8
af11 is starting off with a positive reputation.
Which reminds me I do have an oil leak I haven't tracked down yet it's on the back of the motor up top I just need to get some time to look at it well. Any idea what it might be, I've got a lot of experience with the 7.3 but they don't have issues like the 6.0 does
Reply With Quote
Old 04-20-2014, 11:38 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
No throttle, no power, no pulsing gtkid2002 6.0L Power Stroke Diesel 22 11-11-2014 06:48 PM
Advise for future of my 2007 6.0!!! mahd776 6.0L Power Stroke Diesel 2 02-01-2014 09:53 AM
2007 6.0 out of the blue problem???? mahd776 6.0L Power Stroke Diesel 3 01-30-2014 07:20 AM
No Start...Need Help bigbeariron 6.0L Power Stroke Diesel 47 01-21-2012 06:11 PM
98 Ranger 3.0L V6 Dies when throttle applied mgmoynihan Ranger & B-Series 3 08-25-2007 05:04 PM


Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 12:18 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup