fuel gauge incorrect - Ford Truck Enthusiasts Forums



Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator

fuel gauge incorrect

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-13-2014, 01:40 PM
phase_one phase_one is offline
New User
Thread Starter
 
Join Date: Mar 2014
Posts: 1
phase_one is starting off with a positive reputation.
fuel gauge incorrect

I bought a 2001 expedition from a relative. The fuel gauge when full would read 3/4 tank. Fuel pump was not working. Mechanic shop replace fuel pump before I purchased the vehicle. The fuel gauge will only show 3/4 tank and go down to 1/4 tank. Fuel light never comes on. Ran out of gas twice. I have searched this page, sending unit could be bad is a possible problem. Fuel gauge could be the problem. Any other suggestions. Thanks!
Reply With Quote
  #2  
Old 03-13-2014, 02:19 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 12,138
alloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to behold
It's a problem with the sender in the tank. Is the fuel pump installation under warranty?
Reply With Quote
  #3  
Old 03-17-2014, 07:46 AM
arj1231 arj1231 is offline
New User
 
Join Date: Jan 2014
Posts: 12
arj1231 is starting off with a positive reputation.
had the same problem reading 3/4 when full. Turned out the people I bought it from changed the needles on the guages, with truck running I took apart the glass from the guages, pull the needle off and reposition it to a hair over full, tested with many restarts, and ran the truck near empty to see if gas light come on. no go. changed bulb and now works fine, light comes on about 1/8 tank, not sure if its correct but it works for me
Reply With Quote
  #4  
Old 03-17-2014, 12:45 PM
lv2race's Avatar
lv2race lv2race is offline
Elder User
 
Join Date: Oct 2005
Location: OC Ghetto
Posts: 958
lv2race is gaining momentum as a positive member of FTE.lv2race is gaining momentum as a positive member of FTE.
The float arm could be bent, it happened to me, probably during shipment. I didn't notice or compare it to the old one upon installation. Had to drop the tank again and compare the two to find out it was bent up causing the incorrect reading of more fuel then was in the tank.
Reply With Quote
  #5  
Old 03-17-2014, 01:29 PM
r2millers's Avatar
r2millers r2millers is online now
Postmaster
 
Join Date: Sep 2010
Location: Southern Cal
Posts: 3,302
r2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud ofr2millers has much to be proud of
I agree with all of the above. Since a mechanic installed, I'd take it back to him to ensure the sending unit is positioned correctly.

Did you check with your relative who owned it before to verify it read properly before the new pump.

If so, truly the mechanic needs to make it right.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wonky Fuel Gauge (stuck on full). Kingkong0192 1994.5 - 1997 7.3L Power Stroke Diesel 13 08-19-2016 12:32 AM
Fuel Gauge Issue eutecticpt Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 6 04-24-2015 05:25 PM
76 f100 gauge cluster problem liv2roc 1973 - 1979 F-100 & Larger F-Series Trucks 3 01-06-2013 12:23 PM
fuel guage stuck on full togobefastguy 1999 - 2003 7.3L Power Stroke Diesel 6 06-24-2012 10:37 AM
Fuel gauge acting strange... smallcandle Excursion - King of SUVs 2 10-13-2009 07:35 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 04:59 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.