05 Expedition blows hot air through defrost vents when set in max a/c mode - Ford Truck Enthusiasts Forums



Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator

05 Expedition blows hot air through defrost vents when set in max a/c mode

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-10-2014, 11:29 AM
jbedsole23 jbedsole23 is offline
New User
Thread Starter
 
Join Date: Mar 2014
Posts: 9
jbedsole23 is starting off with a positive reputation.
05 Expedition blows hot air through defrost vents when set in max a/c mode

My 05 Expedition is giving me some trouble. When I turn the a/c on it blows hot air through the defrost vents no matter what I do. I used to have a thumping noise coming from the dash but that stopped. Any help with this would be great.
Reply With Quote
  #2  
Old 03-10-2014, 12:09 PM
alwaysfords41's Avatar
alwaysfords41 alwaysfords41 is offline
Posting Guru
 
Join Date: Feb 2008
Posts: 2,086
alwaysfords41 is gaining momentum as a positive member of FTE.
I'd guess you have two problems. The temperature problem is a broken blend door and the defrost location for the air flow is what happens when you have a vacuum leak - it is the default. The blend door is in the dash and can be fixed by removing the dash, or by using Heater Treater through the back of the glove compartment. The vacuum leak is likely in the area of the battery tray as the lines go through that area and are prone to corrosion.
Reply With Quote
  #3  
Old 03-10-2014, 12:59 PM
jbedsole23 jbedsole23 is offline
New User
Thread Starter
 
Join Date: Mar 2014
Posts: 9
jbedsole23 is starting off with a positive reputation.
I have never heard of heater treater. How exactly would I use that?
Reply With Quote
  #4  
Old 03-10-2014, 06:50 PM
alwaysfords41's Avatar
alwaysfords41 alwaysfords41 is offline
Posting Guru
 
Join Date: Feb 2008
Posts: 2,086
alwaysfords41 is gaining momentum as a positive member of FTE.
It is a metal blend door, they make versions for lots of cars. Heatertreater.com
Reply With Quote
  #5  
Old 03-11-2014, 07:25 AM
jbedsole23 jbedsole23 is offline
New User
Thread Starter
 
Join Date: Mar 2014
Posts: 9
jbedsole23 is starting off with a positive reputation.
I saw that on the internet. I was looking around the battery area last night and saw multiple spots in the vacuum lines that could be the issue. Do you have any idea on what size the vacuum hose is? Some spots it appears to be large tubing and other spots it is very thin. Not sure how to match that up when it goes into the "T".
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2005 Exp not blowing air NottiAlaska Expedition & Navigator 4 10-07-2016 06:31 AM
A/c Damper door problem shakebaker69 1997 - 2003 F150 5 09-03-2013 07:13 PM
in 4wd the a/c blows out the defroster vent?? pickupman2002 6.0L Power Stroke Diesel 21 09-24-2012 03:37 PM
E-350 rv A/C question MDSLIGHT Cooling, Heating, Ventilation & A/C 3 07-28-2011 07:16 AM
A/c blowing through defrost vents 300FOREVER Ranger & B-Series 5 08-03-2010 08:45 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 09:12 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.