Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-10-2014, 10:29 AM
jbedsole23 jbedsole23 is offline
New User
 
Join Date: Mar 2014
Posts: 9
jbedsole23 is starting off with a positive reputation.
05 Expedition blows hot air through defrost vents when set in max a/c mode

My 05 Expedition is giving me some trouble. When I turn the a/c on it blows hot air through the defrost vents no matter what I do. I used to have a thumping noise coming from the dash but that stopped. Any help with this would be great.
Reply With Quote
  #2  
Old 03-10-2014, 11:09 AM
alwaysfords41's Avatar
alwaysfords41 alwaysfords41 is online now
Posting Guru
 
Join Date: Feb 2008
Posts: 1,759
alwaysfords41 is gaining momentum as a positive member of FTE.
I'd guess you have two problems. The temperature problem is a broken blend door and the defrost location for the air flow is what happens when you have a vacuum leak - it is the default. The blend door is in the dash and can be fixed by removing the dash, or by using Heater Treater through the back of the glove compartment. The vacuum leak is likely in the area of the battery tray as the lines go through that area and are prone to corrosion.
__________________
2010 Expedition Limited now @ 27k
2012 Expedition Limited now @ 17k
Gone but not forgotten;
1995 Bronco XLT, 1996 Explorer XLT, 1999 Expedition EB, 2003 Expedition EB, 2004 Expedition EB Premium
Reply With Quote
  #3  
Old 03-10-2014, 11:59 AM
jbedsole23 jbedsole23 is offline
New User
 
Join Date: Mar 2014
Posts: 9
jbedsole23 is starting off with a positive reputation.
I have never heard of heater treater. How exactly would I use that?
Reply With Quote
  #4  
Old 03-10-2014, 05:50 PM
alwaysfords41's Avatar
alwaysfords41 alwaysfords41 is online now
Posting Guru
 
Join Date: Feb 2008
Posts: 1,759
alwaysfords41 is gaining momentum as a positive member of FTE.
It is a metal blend door, they make versions for lots of cars. Heatertreater.com
__________________
2010 Expedition Limited now @ 27k
2012 Expedition Limited now @ 17k
Gone but not forgotten;
1995 Bronco XLT, 1996 Explorer XLT, 1999 Expedition EB, 2003 Expedition EB, 2004 Expedition EB Premium
Reply With Quote
  #5  
Old 03-11-2014, 06:25 AM
jbedsole23 jbedsole23 is offline
New User
 
Join Date: Mar 2014
Posts: 9
jbedsole23 is starting off with a positive reputation.
I saw that on the internet. I was looking around the battery area last night and saw multiple spots in the vacuum lines that could be the issue. Do you have any idea on what size the vacuum hose is? Some spots it appears to be large tubing and other spots it is very thin. Not sure how to match that up when it goes into the "T".
Reply With Quote
Old 03-11-2014, 06:25 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
E-350 rv A/C question MDSLIGHT Cooling, Heating, Ventilation & A/C 3 07-28-2011 06:16 AM
Air coming only from Defrost on 2000 Ford Expedition davh Expedition & Navigator 3 09-27-2010 05:27 PM
A/c blowing through defrost vents 300FOREVER Ranger & B-Series 5 08-03-2010 07:45 PM
A/C vent problem on Wife and My 05's clee2 Cooling, Heating, Ventilation & A/C 3 07-23-2008 07:04 AM
ac vents killer4x4 Cooling, Heating, Ventilation & A/C 1 11-06-2001 02:54 AM



All times are GMT -5. The time now is 04:51 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup