08 f250 5.4- PO420 and 430, rich startup - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)
Log In 


08 f250 5.4- PO420 and 430, rich startup

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-24-2014, 11:06 AM
explorer5.0 explorer5.0 is offline
New User
 
Join Date: Jan 2008
Posts: 11
explorer5.0 is starting off with a positive reputation.
08 f250 5.4- PO420 and 430, rich startup

Not sure where to start with this. This is a beat up farm truck so I dont want to throw a lot of money at it- as in I want to avoid the dealership.

On a cold start, it smokes a good bit- I can tell it is super rich. Otherwise it seems to run pretty good. It feels a little underpowered, but the only comparison I have is a 2010 F150. I assume the 5.4 should be a pig in an f250.

The exhaust note is pretty loud for a stock truck, so I assume the cat substrate is broken up. I am not worried about that as much as the rich startup. I am worried I may have a leaky injector.

The truck has 139k miles, but had a new engine installed at the dealership at ~70k.

There is also a code for PCM failure, Po606 I think. I will have to check that one when I get home.
Reply With Quote
  #2  
Old 02-25-2014, 09:08 AM
JWA's Avatar
JWA JWA is offline
Post Fiend
 
Join Date: Aug 2010
Location: Reynoldsburg, Ohio
Posts: 10,206
JWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputation
Try this---from the comfort of your inside seat: ActronŽ
Reply With Quote
  #3  
Old 02-25-2014, 09:50 AM
explorer5.0 explorer5.0 is offline
New User
 
Join Date: Jan 2008
Posts: 11
explorer5.0 is starting off with a positive reputation.
Quote:
Originally Posted by JWA View Post
Try this---from the comfort of your inside seat: ActronŽ
I shoudl have been more clear. I already know what the codes mean. I am pretty sure my cats are both trashed. I am more worried about the smoky startup.
Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Beginner Questions Bkq15 1999 to 2016 Super Duty 8 08-24-2015 11:26 PM
2000 F150 4wd 5.4 Running full rich gixxer.taylor 1997 - 2003 F150 10 06-01-2015 11:24 PM
03 Expy 5.4 rough idle with cold temperatures fisher23112 Expedition & Navigator 14 02-01-2015 02:22 PM
03 5.4 running rich and now lean 68shortbedmo 1997 - 2003 F150 13 01-04-2015 12:39 PM
Tell me about the 5.4 trucks rich gill 1999 to 2016 Super Duty 39 03-21-2014 02:50 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 05:39 PM.

 

Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup