Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-24-2014, 12:06 PM
explorer5.0 explorer5.0 is offline
New User
 
Join Date: Jan 2008
Posts: 11
explorer5.0 is starting off with a positive reputation.
08 f250 5.4- PO420 and 430, rich startup

Not sure where to start with this. This is a beat up farm truck so I dont want to throw a lot of money at it- as in I want to avoid the dealership.

On a cold start, it smokes a good bit- I can tell it is super rich. Otherwise it seems to run pretty good. It feels a little underpowered, but the only comparison I have is a 2010 F150. I assume the 5.4 should be a pig in an f250.

The exhaust note is pretty loud for a stock truck, so I assume the cat substrate is broken up. I am not worried about that as much as the rich startup. I am worried I may have a leaky injector.

The truck has 139k miles, but had a new engine installed at the dealership at ~70k.

There is also a code for PCM failure, Po606 I think. I will have to check that one when I get home.
Reply With Quote
  #2  
Old 02-25-2014, 10:08 AM
JWA's Avatar
JWA JWA is offline
Post Fiend
 
Join Date: Aug 2010
Location: Reynoldsburg, Ohio
Posts: 7,003
JWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputation
Try this---from the comfort of your inside seat: Actron®
Reply With Quote
  #3  
Old 02-25-2014, 10:50 AM
explorer5.0 explorer5.0 is offline
New User
 
Join Date: Jan 2008
Posts: 11
explorer5.0 is starting off with a positive reputation.
Quote:
Originally Posted by JWA View Post
Try this---from the comfort of your inside seat: Actron®
I shoudl have been more clear. I already know what the codes mean. I am pretty sure my cats are both trashed. I am more worried about the smoky startup.
Reply With Quote
Old 02-25-2014, 10:50 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tell me about the 5.4 trucks rich gill Super Duty & Heavy Duty 39 03-21-2014 03:50 PM
Black smoke from exhaust at startup wluce01 Modular V8 (4.6L, 5.4L) 2 09-30-2013 08:26 PM
Bottom End 96f150 1997 - 2003 F150 1 04-12-2009 01:35 PM
Puff of smoke on Startup Jspafford Super Duty & Heavy Duty 22 03-19-2007 05:53 PM
Need Chip or programmer for 00 F250sd 5.4L 33bronco Computer Chips & Tuners 2 09-12-2006 12:17 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 05:14 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup