Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)
Sign in using an external account
Register Forgot Password?


performance issues

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-14-2014, 08:45 AM
Fordgrl83 Fordgrl83 is offline
New User
 
Join Date: Feb 2014
Posts: 5
Fordgrl83 is starting off with a positive reputation.
performance issues

I have a 2001 Ford F150 5.4 ltr 4x4. / My truck was running great. Replaced the fuel filter and it was an avalanche. She wouldn't run above 15 mph and wouldnt turn over. Acted like she wasn't getting enough gas. Running better now but not where she was. She bogs down acts like she wants to stall out or misfire but she's not sure which if you step on the gas to hard.
These are the parts that I have changed in the year and a half I've had the truck and how long ago they were changed
Intake manifold - 6 months
Spark plugs - 6 months
Ignition coil packs - 6 months
Upper and lower radiator hoses - 6 months

Fuel filter - last week
Idle air control sensor - 5 days
4 O2 sensors - 5 days
Vacuum hoses - 5 days
Mass air flow sensor - 5 days
Fuel pump - 4 days
Fuel lines- 4 days
Fuel regulator - 1 day
I have the throttle positioning sensor
Left to replace.
Reply With Quote
  #2  
Old 02-14-2014, 08:48 AM
JWA's Avatar
JWA JWA is offline
Post Fiend
 
Join Date: Aug 2010
Location: Reynoldsburg, Ohio
Posts: 7,899
JWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputationJWA has a superb reputation
Are there any DTC's showing? Have you done a DTC scan yet?
Reply With Quote
  #3  
Old 02-14-2014, 10:16 AM
Fordgrl83 Fordgrl83 is offline
New User
 
Join Date: Feb 2014
Posts: 5
Fordgrl83 is starting off with a positive reputation.
performance issues

Not since I had the O2 sensors done.
Reply With Quote
  #4  
Old 02-14-2014, 01:05 PM
kbsupercrew's Avatar
kbsupercrew kbsupercrew is offline
Senior User
 
Join Date: Sep 2011
Posts: 423
kbsupercrew is starting off with a positive reputation.
Have you checked the fuel pressure running at the rail?
Reply With Quote
  #5  
Old 02-14-2014, 03:19 PM
Fordgrl83 Fordgrl83 is offline
New User
 
Join Date: Feb 2014
Posts: 5
Fordgrl83 is starting off with a positive reputation.
I have and I replaced the fuel regulator. I changed vacuum hoses near my egr valve also one was collapsed and another had a knife cut in it which makes makes me wonder because I had it in the shop for the o2 sensors and they kept trying to get me to let them do more more...
Reply With Quote
  #6  
Old 02-14-2014, 09:04 PM
kbsupercrew's Avatar
kbsupercrew kbsupercrew is offline
Senior User
 
Join Date: Sep 2011
Posts: 423
kbsupercrew is starting off with a positive reputation.
clogged cat?
Reply With Quote
  #7  
Old 02-15-2014, 01:56 PM
galaxie641 galaxie641 is offline
Postmaster
 
Join Date: Nov 2006
Location: SE Wyoming
Posts: 4,493
galaxie641 has a very good reputation on FTE.galaxie641 has a very good reputation on FTE.galaxie641 has a very good reputation on FTE.galaxie641 has a very good reputation on FTE.
Fuel filter in backwards.
__________________
'51 F3 Flat8
'64 Galaxie 352 4bbl
'72 F250 400/C6
'08 CVPI
'09 F150 5.4L
'10 Mustang GT
Reply With Quote
  #8  
Old 02-15-2014, 01:59 PM
nojoke327's Avatar
nojoke327 nojoke327 is offline
Elder User
 
Join Date: Dec 2011
Location: monroe ct
Posts: 818
nojoke327 has a good reputation on FTE.nojoke327 has a good reputation on FTE.nojoke327 has a good reputation on FTE.
^^^ that was my first thought too
__________________
2000 Excursion xlt 6.8 aka "my big fat ex"

2008 reg cab F350-----sold

US Navy Seabee 07-13. BU2. NMCB 27/22
OEF 09-10 Afghanistan.
Reply With Quote
Old 02-15-2014, 01:59 PM
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
05 5.4 runs very rough jcrook85 2004 - 2008 F150 4 03-07-2015 02:40 PM
6.0 fuel issue Corey Jay Hawkins 6.0L Power Stroke Diesel 15 02-22-2015 08:10 AM
'93 5l V8 - Driving me crazy MotherWolf Small Block V8 (221, 260, 289, 5.0/302, 5.8/351W) 2 11-26-2014 05:08 PM
94 Explorer with wierd problem Redneckfordf2502002 Explorer, Sport Trac, Mountaineer & Aviator 10 06-13-2014 09:20 AM
Misfire in cylinder 5 (P0305) '06 Expedition EB 5.4 3v 83frankenstein250 Expedition & Navigator 10 06-07-2014 06:40 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »


All times are GMT -5. The time now is 08:34 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup