2005 f-350 electrical problem? Need help - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)
Log In 


2005 f-350 electrical problem? Need help

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-11-2014, 10:27 AM
Grizz350 Grizz350 is offline
New User
 
Join Date: Feb 2014
Posts: 1
Grizz350 is starting off with a positive reputation.
2005 f-350 electrical problem? Need help

Started my truck today and it started for couple seconds then I went to turn my headlights on and it died. Now it won't turn over at all not even by gettin jumped got the battery load tested and it was fine. Also every now in the my aftermarket radio would turn on it off to I don't kno if this would cause this's also none of my lights come on inside or outside I put the key in and nothin happens except for a clicking sound like a relay clicking and my speedo is stuck over a hundred and no lights or gauges move when I turn the keys on and also I have to disconnect the battery cause the clicking sound continues even with the keys out ? Any ideas anyone what this could be ?
Reply With Quote
  #2  
Old 02-14-2014, 10:39 PM
LxMan1's Avatar
LxMan1 LxMan1 is offline
Moderator
 
Join Date: Dec 2001
Location: Louisville,Ky.
Posts: 22,304
LxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant futureLxMan1 has a brilliant future
Welcome to the forum. Sounds like you have a bad ground somewhere. Check both ends of the main ground cable and all of the body grounds as well.
__________________
Jimmy- FTE Moderator

88 5.0 LX Mustang
63 F100 351W/C6

Reply With Quote
Old 02-14-2014, 10:39 PM
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ckicking sound in cab KellerMAC 1999 - 2003 7.3L Power Stroke Diesel 6 08-24-2012 03:02 PM
F350 won't start unhcp Super Duty & Heavy Duty 7 11-03-2011 09:11 AM
Clicks but won't start Jrakar 2007 - 2014 Expedition & Navigator 7 11-01-2011 02:56 PM
Starter will not turn over hood Electrical Systems/Wiring 3 01-29-2006 07:40 PM
bronco won't start, even with jumper cables brocobilliam 1978 - 1996 Big Bronco 16 01-03-2006 11:34 AM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 12:28 AM.

 

Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup