Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 02-02-2014, 09:38 PM
kooka7 kooka7 is offline
New User
 
Join Date: Feb 2014
Posts: 8
kooka7 is starting off with a positive reputation.
Emissions Icon on dash and compressor noise - newby pls help

Hi All,
I hope you are well. I am a newby and new to the land of Expeditions. Hubby bought me an 07 Limited Expedition and after a few days of owning it have noticed that there is an ‘emmissions’ solid lamp on the dash.

I have also noticed that upon startup that there seems to be a compressor noise … I have looked at the service manual, trouble shooted and done some research within the forum and would like to ask….

Could anyone please recommend a reputable mechanic that you would trust your life with please?

We are currently in NE Calgary.

I am completely new here and country too (from AU)... use to own a landrover and that was fraught with issues and in the end became quite conversant... however with x5 little ones don't have the time to spend on nutting things out just yet so appreciate some contacts please...

thx in advance...

K7
Reply With Quote
  #2 (permalink)  
Old 02-03-2014, 11:26 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
I would get it into a shop or at least a place that has a code reader and find out what codes are being thrown. Many auto parts stores will read them for free. A scanner can be had for $80 US if you can not find someone to read them for freee. It's a good tool to have.

Once you have the codes you can go from there. Without them anyone would be simply guessing what is causing the light to come on. I wouldn't continue to drive it though without finding out, you could be damagin your catalytic converters which are very expensive.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3 (permalink)  
Old 02-03-2014, 08:39 PM
kooka7 kooka7 is offline
New User
 
Join Date: Feb 2014
Posts: 8
kooka7 is starting off with a positive reputation.
Hello,
Thanks for the reply. I've booked it in to be looked @ by Ford - 140$ it will cost me. I am sure it's something to do with the system most likely needing a good flush. Solid state = needs looking at. Blinking state = don't drive as damage can be caused to cat conv.

Their 120K service offer is in the 1k vacinity also and will most likely get them to do that too as there is absolutely nothing in the service log book and not even a dealer stamp... my cousin pointed me to the windowsticker site where I entered my VIN and a whole myriad of info came up that I would otherwise not have known!

We don't get these in Australia at all... so a good learning curve...

K7

Quote:
Originally Posted by berry1234 View Post
I would get it into a shop or at least a place that has a code reader and find out what codes are being thrown. Many auto parts stores will read them for free. A scanner can be had for $80 US if you can not find someone to read them for freee. It's a good tool to have.

Once you have the codes you can go from there. Without them anyone would be simply guessing what is causing the light to come on. I wouldn't continue to drive it though without finding out, you could be damagin your catalytic converters which are very expensive.
Reply With Quote
  #4 (permalink)  
Old 02-06-2014, 02:11 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Keep us posted. I am interested in seeing what caused this.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #5 (permalink)  
Old 02-11-2014, 10:36 PM
wallz's Avatar
wallz wallz is offline
Posting Guru
 
Join Date: Jan 2008
Location: The Great White North!
Posts: 2,490
wallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud ofwallz has much to be proud of
Quote:
Originally Posted by berry1234 View Post
Keep us posted. I am interested in seeing what caused this.
I think she was saying motor ended up seizing on them. They are working with the used dealer they bought thru, but I don't know their outcome. I guess there were a few other underlying issues also that were not disclosed at purchase.
Welcome to Canada and the used car market.
__________________
2002 Excursion, 4x4, V-10, XLT, RS9000 shocks, true trac diff, 08 alum diff cover, interior light delete, 08 power fold/xtend mirrors, KM2 tires, 5 Star tuned, front cryo powerslots with hawk pads, XRF ball joints. 50" front mounted LED bar, 10" reverse light LED bar. Banks stainless long tube headers and exhaust kit., front seat heaters.
2011 Expedition, Ltd Max, 4x4. 30" LED light bar, flip key fob, 9 passenger, more to come.
Reply With Quote
  #6 (permalink)  
Old 02-11-2014, 11:52 PM
kooka7 kooka7 is offline
New User
 
Join Date: Feb 2014
Posts: 8
kooka7 is starting off with a positive reputation.
Thx Wallz and berry 1234 for both your replies.... well... it's a long winded one...

scenario point form as follows + some elongated wind formed reply hahah:

-------------------------
UNIVERSAL FORD LINCOLN
-------------------------

1. hubby took truck into Universal Ford Lincoln (only taken there from recommendation from folk on the forum!!)....

2. In a nutshell... ford inspected the vehicle, found that the wiring loom was damaged with some under body frame damage. We were cognisant at time of purchase (based on car proof report) that vehicle had been stolen (from BC) but advised no damage as per car proof report (which we think is bollocks anyways now)... upon closer inspection by Ford, advised NOT the case!!

3. Fuel tank was dropped to further investigate and found very damaged wiring harness that in a nut shell had a less than back yarder job done to tape it back together (and I mean literally tape)... even I saw it and it was appalling... but didn't need to have fuel tank dropped to see that!!!

4. Whilst engine was hooked up for diagnosis... just to do that basic troubleshooting cost in the vacinity of $600...no rectification ... just troubleshooting on Fords part... !! I think we got shafted.

5. My husbands opinion of Ford... not alot as they should have seen the issue with the wiring without having taken out the petrol tank so we think we got shafted by them or had an inexperienced mechanic or just their philosophy of doing work that wasn't required.... either way... idiots... we won't ever be going back there again... they took us for a ride.... my husband built his engine (small block 400 in his FJ40 which the entire vehicle is in a container somewhere hitting the shores of canada soon) from the ground up and he is not inept... perhaps he should set those idiots right at universal ford... he has sworn to never go to them again!...

My husband is pretty good with character... and he just felt that they were the sort of people to rip you off, after the fact upon reflection! ... after the fact... and the rapport he had with the indepedent mechanic from the dealer we bought the car from was the opposite...that just says something!

--------------
CAR DEALER (+ ramblings LOL)
--------------

1. Once hubby had the service / mechanical / independent report from Ford... he then approached the dealership that we had purchased the vehicle from. We paid a little under 22K for this cash... so hubby was quite peeved to say the least... and rightly so....as he bought this for me and our 5 munchikins to do the school/kindy/playgroup/church and what ever else run etc...

The dealership was surprised at the findings as they use an independent party to certify all their vehicles... however... we left it with them for the day (today) so they could run their own tests and that of engine compression (engine compression failed from ford)...

Engine compression was found to be more than adequate (65%) and the wiring harness was all repaired, properly that is... each wire was individually traced back, and joined together and sealed appropriately. We have pictures and video of all of the work done too... that in itself says something about the mechanic.

We at this point in time have no further issues as far as errors cropping up on the dash. We have assurances from the dealer that if any crop up they will fix them.

The only thing we need resolved is the DVD but that is secondary...

They are cognisant that if anything crops up we will be lodging a complaint against amvic with them...

Hubby was more than happy with the work done to wiring harness and is happy that the dealership spent the time & money in rectifying these issues...ford only diagnosed and dealer fixed... so we won't be taking this one back to Universal Ford Lincoln any time soon, or ever! we got ripped off by universal and I personally am quite disgusted by that.

However... the same argument can be said for the dealers independent mechanic... however... we were told that the vehicle arrived at the 'lot' after the mechanical report and all was ok... so whether something went askew between that and reaching the actual dealer who knows... questionable...

The managing mechanic as he told us worked with them (universal) for quite some time and was quite disgusted that they charged us so much money for them to have not actually fix anything...

I know personally back home on my landrover... $600 would have got alot done and that's not even factoring in the diagnosis as that was all free (that's how most things work in AU)... so again re-iterate will NOT be going back to universal ford lincoln as their prices are simply too exhorbitant... and certainly question their work ethic.. & we felt got shafted by them.

On another note, I researched through the forum (thanks to Wallz providing some info) in obtaining the code for the door lock pad... when hubby enquired with Ford as to whether they could get that information at the same time given the system was hooked up to their diagnostic system already... we were told that was a different system... even I know that is a load of crap... so many thanks to the folk who posted about obtaining the code ... we may be new to the country but seriously we are not stoopid!

Live and learn I know... hubby is more than happy to take his FJ40 to the mechanic that repaired and resolved our expy issues... he will be sitting in the waiting room though (as if he will let any one run his small block FJ40 for a test LOL!)...if hubby is happy with the mechanicability of the expy and he feels that it is more than adequate as my run about with the kids, I am equally happy too...

If you are in Calgary and would like to know the mechanic we used, please PM me (I am assuming I have this functionality as I am new to the forum)

Eitherway, all sorted I hope.... I have arriving from Australia some window sox... not yet sure how they will hold up to the snow... but awesome eitherway. I had them on my landrover back home and swear by them.... just google them if you are wondering what the hec I am on about...

Cheers,
k7

Last edited by kooka7; 02-12-2014 at 12:09 AM. Reason: additional info
Reply With Quote
  #7 (permalink)  
Old 02-12-2014, 11:44 AM
alwaysfords41's Avatar
alwaysfords41 alwaysfords41 is offline
Posting Guru
 
Join Date: Feb 2008
Posts: 1,734
alwaysfords41 is gaining momentum as a positive member of FTE.
What are you after with the window sox, shading the inside? All the rear windows are already tinted but you could always just tint them again, and tint the fronts. The sox seem like they would be annoying to deal with.
__________________
2010 Expedition Limited now @ 27k
2012 Expedition Limited now @ 17k
Gone but not forgotten;
1995 Bronco XLT, 1996 Explorer XLT, 1999 Expedition EB, 2003 Expedition EB, 2004 Expedition EB Premium
Reply With Quote
  #8 (permalink)  
Old 02-12-2014, 12:23 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Tinting is the way to go for sure. Even peel and stick if you need to remove it.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #9 (permalink)  
Old 02-12-2014, 10:09 PM
kooka7 kooka7 is offline
New User
 
Join Date: Feb 2014
Posts: 8
kooka7 is starting off with a positive reputation.
not at all annoying... windows are already tinted ... there's just heaps of glare... I had the window sox on the landrover for about 5 years and basically put them on and forget - the only thing that killed those in the end were the harsh aussie summers... no hinderance at night either... I just left them on and perfectly legal and I know they work great for filtering out the UV rays for the little ones eyes.... AND they can't throw anything out the window LOL!

I think it will be trial and error to see how they hold up and willing to do that as I know they were great in AU.... and I can give my critique to the manufacturer!
Reply With Quote
  #10 (permalink)  
Old 07-16-2014, 01:24 AM
kooka7 kooka7 is offline
New User
 
Join Date: Feb 2014
Posts: 8
kooka7 is starting off with a positive reputation.
Just an update, I've had the window sox on for a few months now.... I have seen enuf cars in my travels with kids in the back with those roller type suction shades where you can only roll down the window so much OR where there is no shade for them at all... where as compared to the window sox, no problems rolling the window all the way down AND getting UV protection for the kids .... more calgarians should consider them IMO... to me it's a no brainer! It's been a warm enuf summer... Uv rays whilst not blistering like AU are still enuf if you are not use to it....
Reply With Quote
  #11 (permalink)  
Old 07-16-2014, 08:15 AM
alwaysfords41's Avatar
alwaysfords41 alwaysfords41 is offline
Posting Guru
 
Join Date: Feb 2008
Posts: 1,734
alwaysfords41 is gaining momentum as a positive member of FTE.
Tinting is still the way to go for me. No muss, no fuss, no hassles and looks good forever. I tint all my vehicles, and when I was a fire chief I even titnted department vehicles that weren't mine.
__________________
2010 Expedition Limited now @ 27k
2012 Expedition Limited now @ 17k
Gone but not forgotten;
1995 Bronco XLT, 1996 Explorer XLT, 1999 Expedition EB, 2003 Expedition EB, 2004 Expedition EB Premium
Reply With Quote
  #12 (permalink)  
Old 07-22-2014, 10:34 PM
kooka7 kooka7 is offline
New User
 
Join Date: Feb 2014
Posts: 8
kooka7 is starting off with a positive reputation.
Quote:
Originally Posted by alwaysfords41 View Post
Tinting is still the way to go for me. No muss, no fuss, no hassles and looks good forever. I tint all my vehicles, and when I was a fire chief I even titnted department vehicles that weren't mine.
The extra dark tint looks awesome agreed.... if you ever see an expy with window sox wave your hand out the window I am sure it will only be me :-p....

Cheers,
kooka
Reply With Quote
Old 07-22-2014, 10:34 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
loud humming noise buddy316 Expedition & Navigator 1 07-18-2014 10:22 AM
Vacuum leak HerbW 1997 - 2003 F150 11 06-04-2014 08:27 PM
Ford Expedition 1999 untouchable8434 Cooling, Heating, Ventilation & A/C 0 10-13-2013 11:44 PM
'05 Expedition front end growling noise shadetree1980 Expedition & Navigator 3 02-17-2013 02:07 PM
97 Expedition A/C Compressor issues please help Supertommy68 Expedition & Navigator 3 08-09-2012 06:12 PM



All times are GMT -5. The time now is 07:39 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup