Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-21-2014, 07:50 PM
chaostoday chaostoday is offline
New User
 
Join Date: Dec 2010
Posts: 14
chaostoday is starting off with a positive reputation.
06 Expy 4x4 issues

I have a 06 Expy EB with 4x4 issues. I have no A4WD, 4x4 high or 4x4 low.
The 4x4 high light flashes every few mins while driving in A4WD or 4x4 high but the unit is not in 4WD. Tonight I was just spinning in the snow as the front was not engaged even though it was switched on.

I have an ABS light on due to a bad right rear speed sensor and wont have the part till next week. Is this related? Is it causing my 4WD not to work?

I also have a slipping OD in transmission and it pops in and out and rumbles at around 40MPH. Any thoughts? Would love to know a flush would fix but I'm thinking torque convertor or other trans issue. I'm very unhappy about that one. Have a feeling it's going to spell thousands.....

Please help
Reply With Quote
  #2  
Old 01-22-2014, 10:54 AM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,475
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
There are several things it could be, but the most likely is the rear speed sensor on the back of the transfer case.
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
Old 01-22-2014, 10:54 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
F250 4x4 Flashing Help wumunga Super Duty & Heavy Duty 2 08-03-2014 08:12 AM
A4wd light flashing on 1998 Expy dakota23 Expedition & Navigator 11 11-19-2013 12:05 AM
**4X4 won't engage 67nukeford Super Duty & Heavy Duty 10 07-11-2012 10:42 PM
97 Explorer 4WD issue..shift motor? joners Explorer, Sport Trac, Mountaineer & Aviator 0 06-21-2008 09:47 AM
97 4wd Light TSCLAYTON Expedition & Navigator 5 08-14-2006 10:29 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
4wd, abs, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 09:24 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup