Fuse blowing - Ford Truck Enthusiasts Forums



Michigan Chapter Join Chapter, Leader: Toyman

Fuse blowing

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-15-2014, 11:36 AM
officer131 officer131 is offline
Posting Guru
Thread Starter
 
Join Date: Dec 2007
Location: Metro Detroit, MI.
Posts: 1,258
officer131 has a great reputation on FTE.officer131 has a great reputation on FTE.officer131 has a great reputation on FTE.officer131 has a great reputation on FTE.
Fuse blowing

I noticed that my WTS light didn't come on this morning while I was taking the kids to school. Then While driving down the road I noticed all of my dash gauges weren't working.


I hooked the light tester to the fuse box and found my #5 power instrument cluster was blown along with my #35 instrument cluster. So I replaced them and seconds later then both blew again. I was using the fuses that have the new "light goes on when fuse blows" or idiot light for me so I don't have to go through all of them with the tester.


I did replace the batteries last Saturday, but that was a week 1/2 ago. Don't know whats the deal.

Think I should go and check the grounds from all the light accessories.

I did post a thread in the 7.3 form.
Reply With Quote
  #2  
Old 01-16-2014, 05:28 AM
just another truck's Avatar
just another truck just another truck is offline
Post Fiend
 
Join Date: Feb 2007
Location: Sterling Heights,Mi
Posts: 10,402
just another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputation
aL, NOT SITTING HERE WITH PRINTS, WILL TRY A LITTLE LATER TO FIND SOME, BUT does it happen when you go in gear, does it happen just sitting? not WTS would have scared the hell out of me, it would have said my pcm wasn't working. Need me to swing by, let me know when? ( Can not be Friday Night )
Reply With Quote
  #3  
Old 01-16-2014, 07:12 AM
SDElwood's Avatar
SDElwood SDElwood is offline
Official BeerMaster #1
 
Join Date: Apr 2003
Location: Alto, Michigan
Posts: 11,299
SDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputation
ARE YOU SURE ITS not just as SIMPLE AS the relay thing UNDER THE HOOD BECAUSE SOMETIMES that can cause just such a SITUATION.
Reply With Quote
  #4  
Old 01-16-2014, 07:50 AM
officer131 officer131 is offline
Posting Guru
Thread Starter
 
Join Date: Dec 2007
Location: Metro Detroit, MI.
Posts: 1,258
officer131 has a great reputation on FTE.officer131 has a great reputation on FTE.officer131 has a great reputation on FTE.officer131 has a great reputation on FTE.
I think it's under the dash, because in did replace the fuses and they were blowing again. The truck was in park every time.
Reply With Quote
  #5  
Old 01-16-2014, 09:47 AM
just another truck's Avatar
just another truck just another truck is offline
Post Fiend
 
Join Date: Feb 2007
Location: Sterling Heights,Mi
Posts: 10,402
just another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputationjust another truck has a superb reputation
you know the next question, windshield ever replaced?
Reply With Quote
  #6  
Old 01-16-2014, 11:00 AM
Toyman's Avatar
Toyman Toyman is online now
Michigan Chapter Ldr
 
Join Date: Feb 2004
Location: Wayland, MI
Posts: 11,291
Toyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputationToyman has a superb reputation
definitely sounds like a chafed wire behind the dash cluster, or possibly shorting out by main distribution box by the battery.

I hate chasing electrical gremlins, good luck Al.

Nice job on the CAPS no caps Mike....
Reply With Quote
  #7  
Old 01-16-2014, 11:35 AM
SDElwood's Avatar
SDElwood SDElwood is offline
Official BeerMaster #1
 
Join Date: Apr 2003
Location: Alto, Michigan
Posts: 11,299
SDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputationSDElwood has a superb reputation
i DoN't KnOw WhAt YoU ArE tAlKiNg AbOuT mAn.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1982 Ford Bronco Tail light circuit problem Ethan Samora 1978 - 1996 Big Bronco 1 09-15-2015 12:44 AM
1974 F100 in Germany - Questions over questions TheGermanGuy 1973 - 1979 F-100 & Larger F-Series Trucks 39 07-08-2015 08:09 PM
my instrument cluster lights wont work victor9909 1987 - 1996 F150 & Larger F-Series Trucks 0 04-23-2015 11:12 PM
87 Ranger Dashboard Lights AaronEZ Ranger & B-Series 7 12-10-2014 09:49 PM
fuse blowing? officer131 1999 - 2003 7.3L Power Stroke Diesel 9 01-25-2014 10:09 PM


Go Back   Ford Truck Enthusiasts Forums > >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 01:56 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.