Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.4L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-14-2014, 08:26 PM
Dadof4 Dadof4 is offline
New User
 
Join Date: Apr 2013
Posts: 21
Dadof4 is starting off with a positive reputation.
Service engine soon light on,low boost ??

Got in my 08' f350 75,9xx miles on it ,started it up and there it was the little engine icon lit up.started up fine,idles fine,got on the road then noticed it won't make more than 10# of boost no matter how much i push on the pedal.got in the truck again later on same thing but then i get the "drive to clean message" so i drove 25 miles or so and message still there.anybody have any ideas? Could they all be linked together somehow? Gonna get code tomorrow. Only have 1500 miles since last oil n fuel filter changes.drained the water seperator yesterday just like every month. Thanks
Reply With Quote
  #2  
Old 01-14-2014, 11:50 PM
RM2738's Avatar
RM2738 RM2738 is offline
Posting Guru
 
Join Date: Sep 2010
Location: The Woodlands, TX
Posts: 2,154
RM2738 has a very good reputation on FTE.RM2738 has a very good reputation on FTE.RM2738 has a very good reputation on FTE.
DTC's will be helpful...

Is the message "Drive until Clean" appearing or "Cleaning Exhaust Filter?" Is it staying on the cluster the entire time or are you using the System Check feature?
__________________
2010 F250 FX4 King Ranch 6.4L, SWB, 3.55 H&S Mini Maxx, S&B CAI, 4" Powerstroker67 downpipe, 4" aFe Exhaust, 2.5" Leveling Kit, Bilstein 5100's, Rancho Steering Stabikizer, DieselSite Coolant Filter, Fumoto Oil Drain Valve
Reply With Quote
  #3  
Old 01-15-2014, 06:52 AM
Dadof4 Dadof4 is offline
New User
 
Join Date: Apr 2013
Posts: 21
Dadof4 is starting off with a positive reputation.
Quote:
Originally Posted by RM2738 View Post
DTC's will be helpful...

Is the message "Drive until Clean" appearing or "Cleaning Exhaust Filter?" Is it staying on the cluster the entire time or are you using the System Check feature?
. Yes its the " drive until clean" message stays up the whole time if i push a button it tells me push reset to clear but comes back on and stays
Reply With Quote
  #4  
Old 01-15-2014, 10:26 AM
senix's Avatar
senix senix is offline
Moderator
 
Join Date: Aug 2008
Location: Frederick, MD
Posts: 21,000
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
drive to clean will stay on till it has finally come down some on soot levels. Sometimes if pulling a load it would take longer to go away since you are producing as much as you are burning.

Once enough has burned off it should turn to cleaning exhaust filter, that will stay on till complete in this case.

Much different then the normal routine regen.
__________________
Scott-2013 F350 with a lot of tires.
2013 40' 4-slider stoneridge 5th wheel coming in at 15,400; 2015 Lincoln MKC
http://www.ford-trucks.com/guidelines.html

Previous Truck 2008 F250 6.4 with lots of upgrades and a suspension upgrade from Torklift International StableLoads
Reply With Quote
  #5  
Old 01-15-2014, 04:53 PM
golfmedik's Avatar
golfmedik golfmedik is offline
Posting Guru
 
Join Date: Jan 2008
Location: Georgia
Posts: 2,036
golfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant futuregolfmedik has a brilliant future
My bet is one of 3 sensors that monitor the turbo is bad. Had it happen twice now to 2 different 6.4s. Neither would boost, but could rev to redline(if you wanted to) in park.
__________________
Monty
'01 Excursion Limited 4x4 7.3L, 195K, Diablo, AFE, Hellwig Sway bar, Procomp Shocks, Rancho RS5406 Stabilizer(bigger is better), V/B. '08 Ears
'13 F350 6.7L CC DRW 4x4B&W Companion, Viair 10007 Air System, Edge CTS, Ride Rites
2012 Sandpiper 365 SAQ weighing in at 15k
Reply With Quote
  #6  
Old 01-15-2014, 05:00 PM
Dadof4 Dadof4 is offline
New User
 
Join Date: Apr 2013
Posts: 21
Dadof4 is starting off with a positive reputation.
Quote:
Originally Posted by golfmedik View Post
My bet is one of 3 sensors that monitor the turbo is bad. Had it happen twice now to 2 different 6.4s. Neither would boost, but could rev to redline(if you wanted to) in park.
It's goin in to dealer friday as its still under warranty. So will update the situation then.didnt have time to get codes checked today but on my to do list tomorrow.thats kind of what i was thinking some kind of sensor. Thanks for the input always appreciated
Reply With Quote
  #7  
Old 01-15-2014, 05:52 PM
Dadof4 Dadof4 is offline
New User
 
Join Date: Apr 2013
Posts: 21
Dadof4 is starting off with a positive reputation.
Just got code read came up p1335. Ecm has detected a minimum egr position above a calibrated level. Says probable cause short circuit condition or faulty egr valve. I wouldn't doubt a short circuit with my luck because truck went into shop a month ago about alternator problem and it turned out to be chaffed wiring right near plug on alternator.
Reply With Quote
  #8  
Old 01-15-2014, 06:31 PM
Dadof4 Dadof4 is offline
New User
 
Join Date: Apr 2013
Posts: 21
Dadof4 is starting off with a positive reputation.
Quote:
Originally Posted by senix View Post
drive to clean will stay on till it has finally come down some on soot levels. Sometimes if pulling a load it would take longer to go away since you are producing as much as you are burning.

Once enough has burned off it should turn to cleaning exhaust filter, that will stay on till complete in this case.

Much different then the normal routine regen.
I guess i should take it for a long highway run to burn it off.just worried about driving with other p1335 thing going on dont want to wreck anything else
Reply With Quote
  #9  
Old 01-15-2014, 06:51 PM
senix's Avatar
senix senix is offline
Moderator
 
Join Date: Aug 2008
Location: Frederick, MD
Posts: 21,000
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
two separate issues I think.
__________________
Scott-2013 F350 with a lot of tires.
2013 40' 4-slider stoneridge 5th wheel coming in at 15,400; 2015 Lincoln MKC
http://www.ford-trucks.com/guidelines.html

Previous Truck 2008 F250 6.4 with lots of upgrades and a suspension upgrade from Torklift International StableLoads
Reply With Quote
  #10  
Old 01-15-2014, 08:05 PM
GSchretter's Avatar
GSchretter GSchretter is offline
Senior User
 
Join Date: Jan 2000
Location: Irving Texas
Posts: 353
GSchretter is gaining momentum as a positive member of FTE.
Schretter.Works GSchretter Olaf Ludwig
Oops, you got it covered
__________________
2010 F350 Dually
2010 Lincoln MKT
2010 Ford Focus
I guess I love them Fords.

Reply With Quote
  #11  
Old 01-15-2014, 09:05 PM
Dadof4 Dadof4 is offline
New User
 
Join Date: Apr 2013
Posts: 21
Dadof4 is starting off with a positive reputation.
Ok so took it 55 miles on the highway doin 65mph to clean exhuast and all i got was the wrench symbol thrown in the mix.message board now is flashing between drive to clean and wrench symbol.could all 3 (no boost,drive to clean and wrench) be intertwined some how ?
Reply With Quote
  #12  
Old 01-15-2014, 09:15 PM
senix's Avatar
senix senix is offline
Moderator
 
Join Date: Aug 2008
Location: Frederick, MD
Posts: 21,000
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
yes...if you have an egr issue I can see where it is throwing a bunch of exhaust gases. So when you take it in be sure to tell them what you did in an attempt to ensure it was not your driving habits...save them from doing a manual regen till the other issues are looked at.

Wrench light and check engine light issue.
__________________
Scott-2013 F350 with a lot of tires.
2013 40' 4-slider stoneridge 5th wheel coming in at 15,400; 2015 Lincoln MKC
http://www.ford-trucks.com/guidelines.html

Previous Truck 2008 F250 6.4 with lots of upgrades and a suspension upgrade from Torklift International StableLoads
Reply With Quote
  #13  
Old 01-15-2014, 10:02 PM
Dadof4 Dadof4 is offline
New User
 
Join Date: Apr 2013
Posts: 21
Dadof4 is starting off with a positive reputation.
Will do.thanks for the input
Reply With Quote
  #14  
Old 01-17-2014, 01:17 PM
Dadof4 Dadof4 is offline
New User
 
Join Date: Apr 2013
Posts: 21
Dadof4 is starting off with a positive reputation.
Service garage says needs new egr and housing.they have to order it so be a day or so till i get it back.$100 deductible gonna cost me and got free matchbox car rental so not so bad.will see how truck is when i get it back.
Reply With Quote
  #15  
Old 01-19-2014, 05:19 AM
Raven56 Raven56 is offline
New User
 
Join Date: Jan 2014
Posts: 16
Raven56 is starting off with a positive reputation.
I had the same issue one day a few years back. Underwarrenty it was a EGR temp sensor. Made the truck go into a limp mod kinda. Check light and low boost. Hope you get it back on the road.
Reply With Quote
Old 01-19-2014, 05:19 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
6.0l problem bigobass1 6.0L Power Stroke Diesel 5 06-08-2012 12:00 AM
Turbo Boost Mike Harnsberger Super Duty & Heavy Duty 2 11-28-2010 09:03 AM
Truck is fixed............................................. ... lakewood 6.0L Power Stroke Diesel 6 09-19-2010 01:36 PM
ROUSHCharger Help FORD996 2004 - 2008 F150 3 03-03-2010 03:07 PM
Loss of turbo pressure towing heavy load (8000lb) a64armt 6.4L Power Stroke Diesel 16 05-10-2009 10:18 AM


Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.4L Power Stroke Diesel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 05:07 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup