03 expedition will not turn over - Ford Truck Enthusiasts Forums

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Log In 

2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

03 expedition will not turn over

LinkBack Thread Tools Search this Thread
Old 01-02-2014, 12:45 AM
jent v jent v is offline
New User
Join Date: Aug 2013
Posts: 6
jent v is starting off with a positive reputation.
03 expedition will not turn over

I went to the store the other day came back out and my truck would not turn over or do anything when I turned the key. I checked all the fuses #28 #32 #33 #34 and #5 and all were good. I then crossed the starter over and it fired up so I could get it home. I got it a little ways down the road and i noticed the O/D light flashing and the check engine light on. It wouldnt make it up the hill with the pedal mashed to the floor. It wouldnt get over 1000 rpms. I managed to get it back down the hill to auto zone and let them check it with a scanner tool. The codes that were coming up were O2 sensors bank 1 and 2 and tcc solinoid. I finally got it towed home today. I checked all the fuses with a multimeter and they had voltage on them. Is there a way to check the pcm power relay with a multimeter to see if it is good. Any help would be appreciated. Thanks
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS Light - Code C1096 - Fix JustFixIt Expedition & Navigator 3 08-05-2015 05:21 PM
1996 F350 O2 Sensor Codes P135, P136, P141 and P155 jmlkicker 1987 - 1996 F150 & Larger F-Series Trucks 0 08-04-2015 01:00 AM
2008 f250 v10running rough and backfiring at idle Dany Boyd Modular V10 (6.8l) 1 06-29-2015 08:18 PM
01 sport trac won't start rcb1031 Explorer, Sport Trac, Mountaineer & Aviator 19 03-19-2015 04:56 PM
Warning: long post. Lean condition bank 1 and 2, random misfire bamaf150 2004 - 2008 F150 2 09-11-2013 04:03 AM

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

All times are GMT -5. The time now is 10:13 AM.


Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup