Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-01-2014, 11:45 PM
jent v jent v is offline
New User
 
Join Date: Aug 2013
Posts: 6
jent v is starting off with a positive reputation.
03 expedition will not turn over

I went to the store the other day came back out and my truck would not turn over or do anything when I turned the key. I checked all the fuses #28 #32 #33 #34 and #5 and all were good. I then crossed the starter over and it fired up so I could get it home. I got it a little ways down the road and i noticed the O/D light flashing and the check engine light on. It wouldnt make it up the hill with the pedal mashed to the floor. It wouldnt get over 1000 rpms. I managed to get it back down the hill to auto zone and let them check it with a scanner tool. The codes that were coming up were O2 sensors bank 1 and 2 and tcc solinoid. I finally got it towed home today. I checked all the fuses with a multimeter and they had voltage on them. Is there a way to check the pcm power relay with a multimeter to see if it is good. Any help would be appreciated. Thanks
Reply With Quote
Old 01-01-2014, 11:45 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blown fuses with a multimeter, WTH??? GOVTMOD 1973 - 1979 F-100 & Larger F-Series Trucks 9 10-15-2012 08:10 AM
O/D Flashing and Fuse Blowing Help Needed jasvid 1994.5 - 1997 7.3L Power Stroke Diesel 13 05-21-2012 05:00 AM
Lacks power then wont start after injector seals 04yfzkid 1994.5 - 1997 7.3L Power Stroke Diesel 15 10-29-2010 06:07 PM
Lacks power then wont start after injector seals 04yfzkid 1987 - 1996 F150 & Larger F-Series Trucks 2 10-20-2010 07:38 PM
Battery Discharging Tests 89BlackBeauty 1999 - 2003 7.3L Power Stroke Diesel 4 02-26-2009 07:28 PM



All times are GMT -5. The time now is 09:01 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup