Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V10 (6.8l)
Sign in using an external account
Register Forgot Password?


Modular V10 (6.8l) SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #16  
Old 03-21-2014, 04:43 PM
jmo1112 jmo1112 is offline
Junior User
 
Join Date: Mar 2011
Posts: 51
jmo1112 is starting off with a positive reputation.
For the life of me, I cannot find where this leak is coming from. I got a mirror and light and have checked all around top where the injector housing connects to the straight rail. If there's a leak there, it is excellent at hiding. I can literally see gas slowly running down the injector. Somehow, at the exact same time, that little silver lip on the injector housing fills up with gas! I mean, I was under the impression that gas follows the laws of gravity. I cannot see gas running down the injector housing, yet gas pools up inside that lip. This is infuriating. It's hard to see what I need to replace if I can't find the source of the leak.
Reply With Quote
  #17  
Old 07-03-2014, 11:08 PM
jmo1112 jmo1112 is offline
Junior User
 
Join Date: Mar 2011
Posts: 51
jmo1112 is starting off with a positive reputation.
Forgot that I never updated this. Found the leak. It was a cracked O-ring in the the top part of the fuel injector. Getting the rail off was a nightmare, but all is well now. Thanks for the help.
Reply With Quote
Old 07-03-2014, 11:08 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!!..EX MISSING ON CYLINDER 1 Jkelley Excursion - King of SUVs 80 11-25-2013 12:50 PM
Poor gas mileage after new plugs and COP's jmo1112 1968-2013 Full Size Vans 2 11-06-2013 11:54 AM
infamous cop problem ole_smokey_88 1997 - 2003 F150 3 01-29-2013 03:15 PM
Just changed plugs & COP's on F250 Utah F250 1997 - 2003 F150 3 02-13-2011 11:46 AM
slight stuttering on acceleration/ COPs? kynnhoj 1968-2013 Full Size Vans 0 12-05-2006 07:45 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V10 (6.8l)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 12:40 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup