Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997 - 2003 F150
Sign in using an external account
Register Forgot Password?


1997 - 2003 F150 1997-2003 F150, 1997-1999 F250LD, 7700 & 2004 F150 Heritage SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-26-2013, 03:07 PM
Shernius Shernius is offline
Senior User
 
Join Date: Feb 2003
Location: New Jersey
Posts: 309
Shernius is starting off with a positive reputation.
Low idle 1999 5.4 f150 with no codes

The truck ran fine this morning and this afternoon I had trouble with the truck running at idle.

The idle is at about 450RPM in park. Runs smooth with no miss but if you bring the idle up and then let off quickly it stalls. Can stall while trying to idle at warm up also. Sometimes it will stall at a light but I think it is related to taking my foot off the pedal quickly.

There is no check engine light on and there are no codes.

I have 138K on the engine now. Both air & fuel filter were replaced about a month ago as well as the PCV valve.
__________________
99 F150 XLT 4X4 SuperCab 5.4L
Reply With Quote
  #2  
Old 10-26-2013, 04:04 PM
Shernius Shernius is offline
Senior User
 
Join Date: Feb 2003
Location: New Jersey
Posts: 309
Shernius is starting off with a positive reputation.
Replaced the plugs at about 105K.

Replaced the MAF about two months ago. Had no noticeable conditions but the check engine light came on and I got codes.

Cleaned out the AIC valve around 4 years ago but had different conditions like stumbling while cruising at highway speeds and idle dropping when stopping at the light. The idle with the AIC vale problem always came back up to normal. *Just found my old post from 4 years ago and it seams I did have similar conditions but the truck threw a code back then. Maybe I need to get someone else to read for codes.
__________________
99 F150 XLT 4X4 SuperCab 5.4L
Reply With Quote
  #3  
Old 10-26-2013, 05:04 PM
projectSHO89 projectSHO89 is offline
Post Fiend
 
Join Date: Jan 2004
Location: St Louis
Posts: 9,401
projectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud of
It's either a vacuum leak or it's a sluggish IAC valve.
__________________
2001 F250 SD V10 4x4
HVAC FAQs: http://www.ford-trucks.com/forums/75...xpedition.html
Owner's manuals: http://www.fleet.ford.com/maintenance/owner-manuals/
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.” - Mark Twain
Reply With Quote
  #4  
Old 10-26-2013, 05:53 PM
Shernius Shernius is offline
Senior User
 
Join Date: Feb 2003
Location: New Jersey
Posts: 309
Shernius is starting off with a positive reputation.
I sprayed around with some starting fluid and the idle didn't jump up so It could be the AIC valve.
__________________
99 F150 XLT 4X4 SuperCab 5.4L
Reply With Quote
  #5  
Old 10-26-2013, 09:30 PM
projectSHO89 projectSHO89 is offline
Post Fiend
 
Join Date: Jan 2004
Location: St Louis
Posts: 9,401
projectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud ofprojectSHO89 has much to be proud of
That trick rarely, if ever, works with modern computer-controlled engines.
__________________
2001 F250 SD V10 4x4
HVAC FAQs: http://www.ford-trucks.com/forums/75...xpedition.html
Owner's manuals: http://www.fleet.ford.com/maintenance/owner-manuals/
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.” - Mark Twain
Reply With Quote
  #6  
Old 10-27-2013, 05:23 PM
Spotty Spotty is offline
Elder User
 
Join Date: Jan 2006
Location: Minnesota
Posts: 891
Spotty is gaining momentum as a positive member of FTE.
Mine has done that on and off for years. If you have worked on it you know where the IAC valve is. I tap mine with the handle end of a big screwdriver and she idles right up and I'm good sometimes for months. I am so disgusted in the quality of replacement parts these days,that the original sporadic one that is almost 16 years old is probably better then a new one...maybe.
__________________
2002 F-150 5.4 4x4 Supercab FX4
2000 Mustang GT, Vert. 5-speed
Reply With Quote
  #7  
Old 10-27-2013, 07:02 PM
Shernius Shernius is offline
Senior User
 
Join Date: Feb 2003
Location: New Jersey
Posts: 309
Shernius is starting off with a positive reputation.
That's what it was alright. I lost a socket and short extension down between the intake runners and into the valley. I can forget about getting those back.
__________________
99 F150 XLT 4X4 SuperCab 5.4L
Reply With Quote
Old 10-27-2013, 07:02 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
truck giving me fits(stalling now) Jeramyb 1987 - 1996 F150 & Larger F-Series Trucks 0 08-03-2014 09:57 PM
MAF or EGR? ruskc1 1997 - 2003 F150 7 02-28-2010 07:54 AM
1990 7.3 stalling. michaelbrainardatwor Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 3 11-10-2009 02:34 PM
03 explorer 4.6 stalls at stop light MAKO314 Explorer, Sport Trac, Mountaineer & Aviator 3 04-20-2008 12:18 PM
98 5.4L rough idle and 4 OBD II codes? RADVRA 1997 - 2003 F150 6 08-14-2003 12:16 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997 - 2003 F150

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 04:29 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup