Go Back   Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


1999 - 2003 7.3L Power Stroke Diesel SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-26-2013, 12:52 PM
Smokiesman's Avatar
Smokiesman Smokiesman is offline
Posting Guru
 
Join Date: May 2006
Location: Bryson City NC
Posts: 1,289
Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.
NO SPEEDO !

My friend picked up a really nice 01 F350 at auction the other nite. Most of the cluster seems to work other than the speedo! Also getting the blinkin lite on the OD button which is suppose to be stored trans codes. We took it to our local shop who used the correct scanner but could not pull any codes.So I picked up a new cluster and we installed and still no joy? We are installing a new VSS sensor today. My question is that I read on some other forums that the front ABS sensor are interconnected to the rear VSS and sends a combined signal to the PCM! Does that sound right ? Hate to take to the stealer so if any ideas out there I am all ears and the Cruise Con doesn't work!! Thanks

Smokie
__________________

BigRed 2
Face lifted
2001 F350 Dually PSD 4x4
Banks Equipped
DP Tuned
Reply With Quote
  #2  
Old 10-26-2013, 01:28 PM
ebbnflow's Avatar
ebbnflow ebbnflow is online now
Senior User
 
Join Date: Sep 2006
Posts: 113
ebbnflow is starting off with a positive reputation.
On my truck, OD light blinked randomly, speedo stopped working, but also my go pedal stopped working. Turned out to be a blown fuse caused by a short in the wire going to the OD button in the shifter. I forget which fuse blew. I replaced shifter and problem is gone.
__________________
2002 F250 CC SRW 7.3 - DP Tuner - Quadzilla Commander (EGT, EOT, ICP, Trans Temp) - Glowshift on Pillar (FP, OP, Boost) - 55 gallon Fuel Tank (Hutched and Harpooned) - Riff Raff 6/6 Wheel - EBPV Delete - Non EBPV Pedestal - Bellowed Uppies - AIH Delete - MBRP 4" Turbo Back Exhaust - BTS Valve Body - Pete's Filter Cover on 6637 - CAT ELC - Fumoto Drain - 35" Toyo MT's - 2" Leveling Kit - 100% Biodiesel - AE Support if you live near Chico, CA - PM me!
Reply With Quote
  #3  
Old 10-26-2013, 01:32 PM
Smokiesman's Avatar
Smokiesman Smokiesman is offline
Posting Guru
 
Join Date: May 2006
Location: Bryson City NC
Posts: 1,289
Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.
The guy at the shop said he checked the fuses ! He is pretty good but I think they need to be checked again! Thanks for the tip!

Smokie
__________________

BigRed 2
Face lifted
2001 F350 Dually PSD 4x4
Banks Equipped
DP Tuned
Reply With Quote
  #4  
Old 10-26-2013, 03:12 PM
Christof13T's Avatar
Christof13T Christof13T is offline
The Dr. will see you now!
 
Join Date: Apr 2012
Location: Victoria, Tx
Posts: 2,435
Christof13T has much to be proud ofChristof13T has much to be proud ofChristof13T has much to be proud ofChristof13T has much to be proud ofChristof13T has much to be proud ofChristof13T has much to be proud ofChristof13T has much to be proud ofChristof13T has much to be proud ofChristof13T has much to be proud ofChristof13T has much to be proud of
christof13t
Had a similar gremlin with motorbug.
No speedo... od light would flash like clockwork as soon as overdrive would normally be dropping in. Turned out to be wet gem/fusebox from leaking roof marker lights.
No luck with hairdryer... it just took a few days and it just started working like normal.
Sealed up my roof markers and have not since had any electrical gremlin shenanigans..
__________________
Chris-PAA#130
Motorbug:2000 F350 Lariat CC,LB,6x6 7.3DIT,4" Turbo-Back, IH Bellowed Uppies, RiffRaff FRx&AIH Delete, Hutch/Harpoon,6637, 05-07facelift, dual cowl induction hood, Glowshift Max Tow gauges, antique BullyDog 1 Toon chip, 10k, Air Lift on rear axle, All the hitches!
420k & counting AE Total Ford Enhanced Bundle
Reply With Quote
  #5  
Old 10-26-2013, 07:05 PM
stinson 108-1's Avatar
stinson 108-1 stinson 108-1 is offline
stinson 108-1
 
Join Date: Jan 2012
Location: south jersey
Posts: 860
stinson 108-1 has a very good reputation on FTE.stinson 108-1 has a very good reputation on FTE.stinson 108-1 has a very good reputation on FTE.
Blinking od light, no cruise and no speedo is classic vss. Get an oem for the better fix if you can. Aftermarket is ok short term. My experience is they seem more trouble free than a cps, but oem is usually the way to go.
__________________
99, 7.3, F350 4x4 CC/DRW, Lariat, ordered new, 96,xxx mi. block#961693, JW. trans, DP F-5 live tuned, 8 Performax guages, 650 dash, 6.0 T cooler, AIS, 38R with RR billet wheel, big head, IH bellows, turbo back ss exh, trans & coolant filters, FS 2500 oil bypass filter, RR P-inserts,boots, frx, hpx, Hutch mod., Transferflo 60. gal tank, Air-Lift, Evans coolant.
JIM.
Reply With Quote
  #6  
Old 10-26-2013, 09:51 PM
caverjoe's Avatar
caverjoe caverjoe is offline
Posting Guru
 
Join Date: Apr 2007
Location: Harrisonville Missouri
Posts: 1,174
caverjoe has a very good reputation on FTE.caverjoe has a very good reputation on FTE.caverjoe has a very good reputation on FTE.
Mine did the same thing years ago. I took it in and I am guess it is the vss like stinson said sept I dont realy know what that is. Mech said it was a sensor down by the transmission. (? speed sensor maybe)
__________________
JOE
2014 6.7 CCSB F250 LARIAT 4X4 30k MILES
E99 F250 Lariat 4x4 EC, AE, 315k miles, 4in turbo back 6637 "
T-500, RedHead
2003 Navigator Ultimate (Stock)
all men are created equal' Then a few become MARINES'"
Reply With Quote
  #7  
Old 10-26-2013, 10:43 PM
Smokiesman's Avatar
Smokiesman Smokiesman is offline
Posting Guru
 
Join Date: May 2006
Location: Bryson City NC
Posts: 1,289
Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.
Joe ! the sensor is in the rear diff! My bud picked up one from Advance! I hope it is not a POS!

Smokie
__________________

BigRed 2
Face lifted
2001 F350 Dually PSD 4x4
Banks Equipped
DP Tuned
Reply With Quote
  #8  
Old 10-28-2013, 09:18 PM
caverjoe's Avatar
caverjoe caverjoe is offline
Posting Guru
 
Join Date: Apr 2007
Location: Harrisonville Missouri
Posts: 1,174
caverjoe has a very good reputation on FTE.caverjoe has a very good reputation on FTE.caverjoe has a very good reputation on FTE.
Quote:
Originally Posted by Smokiesman View Post
Joe ! the sensor is in the rear diff! My bud picked up one from Advance! I hope it is not a POS!

Smokie
good to know thank you
__________________
JOE
2014 6.7 CCSB F250 LARIAT 4X4 30k MILES
E99 F250 Lariat 4x4 EC, AE, 315k miles, 4in turbo back 6637 "
T-500, RedHead
2003 Navigator Ultimate (Stock)
all men are created equal' Then a few become MARINES'"
Reply With Quote
  #9  
Old 10-28-2013, 11:52 PM
Smokiesman's Avatar
Smokiesman Smokiesman is offline
Posting Guru
 
Join Date: May 2006
Location: Bryson City NC
Posts: 1,289
Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.
Update ! We replaced the sensor in the diff and double checked all the fuses and still no joy! Looks like it might have to go in the shop!!!

Smokie
__________________

BigRed 2
Face lifted
2001 F350 Dually PSD 4x4
Banks Equipped
DP Tuned
Reply With Quote
  #10  
Old 10-29-2013, 06:03 AM
scottnchrissy's Avatar
scottnchrissy scottnchrissy is offline
Junior User
 
Join Date: Jul 2008
Location: North Idaho
Posts: 61
scottnchrissy is starting off with a positive reputation.
I don't have an auto trans but I have read about the OD wire chaffing and causing problems. Look up the failure prevention thread.
__________________
Scott
2000 F350 4X4 CC LB 6 Speed. 164,000
Ford AIS, CCV vented at rear axle, FRx, HPx, 4" MBRP turbo back w/muffler, Boost and pyro guages, Riffraff boots, plenum reinforcements and 6x6 billet compressor wheel. Shell ELC, Ranger valve mod. To do, coolant and oil bypass filters.
Reply With Quote
  #11  
Old 10-29-2013, 10:16 AM
caverjoe's Avatar
caverjoe caverjoe is offline
Posting Guru
 
Join Date: Apr 2007
Location: Harrisonville Missouri
Posts: 1,174
caverjoe has a very good reputation on FTE.caverjoe has a very good reputation on FTE.caverjoe has a very good reputation on FTE.
Quote:
Originally Posted by scottnchrissy View Post
I don't have an auto trans but I have read about the OD wire chaffing and causing problems. Look up the failure prevention thread.
R U talking about the wires at the steering column Scott?
__________________
JOE
2014 6.7 CCSB F250 LARIAT 4X4 30k MILES
E99 F250 Lariat 4x4 EC, AE, 315k miles, 4in turbo back 6637 "
T-500, RedHead
2003 Navigator Ultimate (Stock)
all men are created equal' Then a few become MARINES'"
Reply With Quote
  #12  
Old 10-29-2013, 10:23 AM
scottnchrissy's Avatar
scottnchrissy scottnchrissy is offline
Junior User
 
Join Date: Jul 2008
Location: North Idaho
Posts: 61
scottnchrissy is starting off with a positive reputation.
Quote:
Originally Posted by caverjoe View Post
R U talking about the wires at the steering column Scott?
Those are the ones.
__________________
Scott
2000 F350 4X4 CC LB 6 Speed. 164,000
Ford AIS, CCV vented at rear axle, FRx, HPx, 4" MBRP turbo back w/muffler, Boost and pyro guages, Riffraff boots, plenum reinforcements and 6x6 billet compressor wheel. Shell ELC, Ranger valve mod. To do, coolant and oil bypass filters.
Reply With Quote
  #13  
Old 10-29-2013, 12:19 PM
BillyBob69's Avatar
BillyBob69 BillyBob69 is offline
Post Fiend
 
Join Date: Jul 2003
Location: Elizabeth, CO
Posts: 6,540
BillyBob69 is a name known to allBillyBob69 is a name known to allBillyBob69 is a name known to allBillyBob69 is a name known to allBillyBob69 is a name known to allBillyBob69 is a name known to all
Quote:
Originally Posted by scottnchrissy View Post
I don't have an auto trans but I have read about the OD wire chaffing and causing problems. Look up the failure prevention thread.
Ditto. I had the same issue on my E99 and it was a chaffed wired. Just added about 2 inches of length for addition play and less pulling rubbing when tilting the steering wheel and all is good for about 7 yrs now.
__________________
99 F350SD Lariat Crew Cab 7.3L PSD - 4x4 - DP Tuner - Custom HD trans
86 Bronco 302 EFI (Second one!)
Quit whining! You voted for him!
http://i86.photobucket.com/albums/k102/billybob69_photo/90x90_email_signature_HIGHMILER-1.png
Reply With Quote
  #14  
Old 11-04-2013, 06:56 PM
Smokiesman's Avatar
Smokiesman Smokiesman is offline
Posting Guru
 
Join Date: May 2006
Location: Bryson City NC
Posts: 1,289
Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.Smokiesman has a very good reputation on FTE.
Update: sort of! My buddy took it to the dealer and and they can get no ABS signal! Said he needs a new ABS to the tune of hold onto yer butt $1800.00 ! So today we made a trip to the boneyard in Asheville and got one for $100. go figure. So now they are going to install and we wait on the results!! This will be interesting? Will keep ya posted!!

Smokie
__________________

BigRed 2
Face lifted
2001 F350 Dually PSD 4x4
Banks Equipped
DP Tuned
Reply With Quote
  #15  
Old 11-04-2013, 10:25 PM
Bonanza35 Bonanza35 is offline
Postmaster
 
Join Date: Sep 2005
Location: Norco,CA
Posts: 4,915
Bonanza35 has a very good reputation on FTE.Bonanza35 has a very good reputation on FTE.Bonanza35 has a very good reputation on FTE.
Got to see what happens here.
Reply With Quote
Old 11-04-2013, 10:25 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo/VSS/P0528/P0500 HELP Devilmanak Super Duty & Heavy Duty 10 04-14-2014 10:56 PM
7.3 turb idi no speedo mroth2008 1987 - 1996 F150 & Larger F-Series Trucks 2 12-28-2013 08:18 PM
VSS Sensor wiring problem jbaynor 1968-2013 Full Size Vans 1 12-23-2012 10:28 PM
Speedometer Issues VSS or Dash cluster ? Whitey99 1999 - 2003 7.3L Power Stroke Diesel 8 02-22-2010 05:20 PM
AAaarrrgghhh!! Speedo STILL bouncing oldblue31 1994.5 - 1997 7.3L Power Stroke Diesel 17 05-27-2007 11:30 PM


Go Back   Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup