Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Mid-West Region > Indiana Chapter
Sign in using an external account
Register Forgot Password?


Indiana Chapter Join Chapter , Leader:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-09-2013, 12:53 PM
Tray Zook Tray Zook is offline
New User
 
Join Date: Oct 2013
Posts: 1
Tray Zook is starting off with a positive reputation.
1990 f150 lariat

hello guy I have a 1990 f150 lariat. it has a 5.0 with the efi and im having a lot of trouble getting her to run right.. on the carb / throttle body there is a sensor on the front by the two intake tubes and when I plug that in the truck screams at about 2100 rpm idle ... but will take off real smooth and it has power . I dont know how to get that idle down ? when I unplug the sensor the truck idles down at a good rpm but the truck feels like it is getting too much gas and not enough air and it bogs down on take off and it has no power.. please excuse if I called things by the wrong name im young and I dont have a lot of experience with gasoline engines. if anyone can help or is willing to talk to me about this id appreciate it very much.

and also I have another problem ,. my oil pressure gauge is not working in the dash anymore, its not at zero but it doesn't flux at all anymore , this just started yesterday but I am pretty sure the truck has oil pressure still. I just was wondering if anyone can tell me where the sending unit or whatever its called is located ? ive saw some people say its by the filter but I dont think that's where mine is located. and help I can get is much appreciated I love my truck and I want to get her running good again!
Reply With Quote
Old 10-09-2013, 12:53 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Mid-West Region > Indiana Chapter

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
no power no smoke jt46321 Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 4 08-03-2014 10:21 PM
1990 4.9 Auto Hesitation/Stall Issues, Help? TurtleTruckSC 1987 - 1996 F150 & Larger F-Series Trucks 4 03-30-2014 12:34 PM
start up idle drop might be the breaking point for my 5.4(updated) SuperDutyScaler Super Duty & Heavy Duty 45 06-29-2013 01:14 PM
07 Lariat 5.4 Low Rough Idle Ice Dragon Racing 2004 - 2008 F150 12 06-17-2013 11:05 AM
04 F350 Dies as soon as i let off the accelerator? Help! Allthingsmarine 6.0L Power Stroke Diesel 39 03-24-2013 05:53 PM



All times are GMT -5. The time now is 02:27 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup