Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > EcoBoost (3.5L, 2.0L)
Sign in using an external account
Register Forgot Password?


EcoBoost (3.5L, 2.0L) 3.5L Twin Turbo EcoBoost V6 and 2.0L I4 EcoBoost Engines

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-30-2013, 12:50 PM
mrad mrad is offline
Senior User
 
Join Date: Mar 2008
Location: Princeton, MN
Posts: 225
mrad is gaining momentum as a positive member of FTE.
Under 800 miles and already being towed back to dealer

Three weeks ago my dad bought a new F-150 eco-boost. He called me this morning and told me the dealership had to send a tow truck out to tow the truck in. It wouldn't start.

He told me was had a couple times last week where it didn't want to start and after attempted tries, it finally started. Yesterday he went out to start it and could not get the doors to unlock. When he finally did, different lights on the dash would intermittently go on. The truck would not start again and the blinkers and flashers would intermittently go on.

The dealer came out today with a flat bed tow truck. Got it started but could not get it out of park. They finally got in on the truck and hauled it away. Anyone heard of similar issues?

I have a feeling he is going to wish he had purchased on 2014 silverado.
__________________
2003 XLT 4x4, V10 4.30
front and rear factory sway bar, SCT 5-Star Tune, RAS, 26 Row 6.0L Transmission cooler, Andersone WD/Sway Control Hitch, Towing Sabre 30BHDS
Reply With Quote
  #2  
Old 09-30-2013, 07:42 PM
tseekins's Avatar
tseekins tseekins is offline
Moderator
 
Join Date: Jan 2008
Location: Hampton, Virginia
Posts: 19,173
tseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputation
This certainly isn't an ecoboost problem.
__________________
Tim
SCPO United States Coast Guard Retired
2011 F-150 XLT 4x4 Ecoboost
2010 Ford Focus
2004 Expedition XLT 4x2

FTE Guidelines
Reply With Quote
  #3  
Old 10-04-2013, 04:12 PM
bdmcdonald bdmcdonald is offline
Senior User
 
Join Date: Dec 2004
Location: Calgary, Alberta
Posts: 204
bdmcdonald is starting off with a positive reputation.
Tell him to go buy his Siverado, I'm sure he'll be very happy.
__________________
2012 F150 FX4 3.5 V6 Eco Boost, 6 Spd auto, 3.73 Electric Lock Diff, Sony Sound system, Sync, etc etc etc Blue with Black Leather
Reply With Quote
  #4  
Old 11-19-2013, 08:56 PM
PWJE PWJE is offline
Junior User
 
Join Date: Nov 2013
Location: Donmore PA
Posts: 56
PWJE is starting off with a positive reputation.
Quote:
Originally Posted by mrad View Post
Three weeks ago my dad bought a new F-150 eco-boost. He called me this morning and told me the dealership had to send a tow truck out to tow the truck in. It wouldn't start.

He told me was had a couple times last week where it didn't want to start and after attempted tries, it finally started. Yesterday he went out to start it and could not get the doors to unlock. When he finally did, different lights on the dash would intermittently go on. The truck would not start again and the blinkers and flashers would intermittently go on.

The dealer came out today with a flat bed tow truck. Got it started but could not get it out of park. They finally got in on the truck and hauled it away. Anyone heard of similar issues?

I have a feeling he is going to wish he had purchased on 2014 silverado.
Id put money on it being something electrical
With the doors not unlocking and the lights it has to be

Id put my money on some kind of electrical control system being falty or their being a bad wiring connection in the truck

It does suck that it had to be towed in and im not gonna make excuses but problems do happen with new cars, trucks, suv's
Think about how many f-150's they make every single day and what a small number actually have problems though and its really small numbers


Your dad will get it all fixed up on fords dime and if he has two more major problems he can file a lemon law claim and get his money back for the truck !

Its all good
Reply With Quote
  #5  
Old 11-20-2013, 11:37 AM
DutchmanAZ DutchmanAZ is offline
Senior User
 
Join Date: Oct 2001
Posts: 285
DutchmanAZ is starting off with a positive reputation.
It's probably a problem with the security system. I've had issues with dealer installed systems in the past, and on other vehicles.
Reply With Quote
Old 11-20-2013, 11:37 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > EcoBoost (3.5L, 2.0L)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A quick conversation with a friend about my wife's car FordmanNJ General Automotive Discussion 8 03-10-2014 03:49 PM
Sold truck now it won't start BlackNM6.0 6.0L Power Stroke Diesel 17 04-04-2013 05:46 PM
Finally "worked" the new SD a little yesterday Slowpoke Slim Super Duty & Heavy Duty 22 01-11-2013 09:54 PM
my transmission story ... advice, please. brettdacosta 1999 - 2003 7.3L Power Stroke Diesel 37 11-17-2012 10:27 AM
Too many problems to know where to start brandon. 1966 - 1977 Early Broncos 2 08-08-2012 09:10 PM



All times are GMT -5. The time now is 01:53 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup