MAP sensor - broken - Ford Truck Enthusiasts Forums



Australia Chapter Join Chapter , Leader: ChunderDownUnder

MAP sensor - broken

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-28-2013, 06:00 AM
SSSimon SSSimon is offline
Posting Guru
Thread Starter
 
Join Date: Apr 2010
Location: Canberra Australia
Posts: 1,158
SSSimon has a great reputation on FTE.SSSimon has a great reputation on FTE.SSSimon has a great reputation on FTE.SSSimon has a great reputation on FTE.
MAP sensor - broken

I knocked the MAP sensor with the IC tube and broke the pressure intake off. On removal I noticed that it has been broken before and stuck together with silicon.

Any recommendations of where to get a replacement?

Is there any issue with running without it? I plugged up the hose. CEL is not on - the body of the old map is in the toolbox,
Reply With Quote
  #2  
Old 09-28-2013, 07:20 AM
SSSimon SSSimon is offline
Posting Guru
Thread Starter
 
Join Date: Apr 2010
Location: Canberra Australia
Posts: 1,158
SSSimon has a great reputation on FTE.SSSimon has a great reputation on FTE.SSSimon has a great reputation on FTE.SSSimon has a great reputation on FTE.
Picked one up at RockAuto.com

https://www.rockauto.com/catalog/moreinfo.php?pk=607433

AUD$125 including Fedex express
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Map Pocket Trim Ring AubreyA3 1961 - 1966 F-100 & Larger F-Series Trucks 10 08-16-2016 08:38 PM
EBP and Map locations KDAVID1 6.0L Power Stroke Diesel 4 11-14-2014 03:23 PM
Compare Baro,EBP,MAP on TorquePro Cell's 1999 - 2003 7.3L Power Stroke Diesel 4 10-02-2014 04:43 PM
Map sensor location v10 ? Jnowaczyk Modular V10 (6.8l) 2 11-05-2013 03:55 AM
MAP Sensor voltage ??? pjnadon 6.0L Power Stroke Diesel 3 01-22-2011 11:01 PM


Go Back   Ford Truck Enthusiasts Forums > >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 09:36 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.