GPS not working - Ford Truck Enthusiasts Forums



Ford In-Vehicle Tech Discussion area for Ford Sync, Sync AppLink, MyFord Touch, Ford Supplied SiriusXM Radio, Ford Work Solutions, etc.

GPS not working

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-15-2013, 09:26 PM
montey2005 montey2005 is offline
Senior User
Thread Starter
 
Join Date: May 2012
Location: Frisco, TX
Posts: 383
montey2005 is gaining momentum as a positive member of FTE.montey2005 is gaining momentum as a positive member of FTE.
GPS not working

Have a 2012 f250 with MyTouch and yesterday I noticed the GPS has no signal. I've looked for the "hard" reset but can't find it. I'm hoping that's all I need but if anyone has had the same experience please chime in. Instructions on hard reset would be welcomed please.
Thanks
Reply With Quote
  #2  
Old 09-18-2013, 07:19 AM
redford's Avatar
redford redford is offline
Moderator
 
Join Date: Sep 2000
Location: Wausau WI
Posts: 17,938
redford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputation
Moving thread to Ford In-Vehicle Tech forum to get you some help.
Reply With Quote
  #3  
Old 09-19-2013, 10:00 AM
Krewat's Avatar
Krewat Krewat is offline
Super Moderator
 
Join Date: Jul 2002
Location: Long Island USA
Posts: 36,747
Krewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputation
There is a TSB for certain models of vehicle, like my 2013 Taurus, there is an update to the GPSM (GPS module) software to cure an issue like this one. There was also a TSB (not for the F-series that I know of though) where the GPSM was too close to some other module, and fitting a revised mounting bracket fixed it. Then, there are people who report that the satellite antenna needed to be replaced.

I've found that even though a "master reset" was done through the MyTouch screen, it doesn't completely reset everything. The only way to get everything in one shot is to disconnect the battery for a 1/2 hour or more and then reconnect and see if it helps.

In my Taurus, the SiriusXM traffic display wouldn't get data, and a master reset didn't clear it up. The only thing that worked was pulling the battery cable. Of course, I probably could have found the fuse to the navigation system, but it was easier to disconnect the battery for an hour

If you have the time, take it to a dealer and let them handle it.

Disconnect the battery first though, and report back !
Reply With Quote
  #4  
Old 09-19-2013, 10:15 AM
montey2005 montey2005 is offline
Senior User
Thread Starter
 
Join Date: May 2012
Location: Frisco, TX
Posts: 383
montey2005 is gaining momentum as a positive member of FTE.montey2005 is gaining momentum as a positive member of FTE.
thanks. I took it to the dealer and it turns out the connector under the headliner rattled loose and it could not be fitted back on so a new one was put in. I guess too much off-roading but I'd rather find these items now while it's under warranty.
Reply With Quote
  #5  
Old 09-19-2013, 11:45 AM
Krewat's Avatar
Krewat Krewat is offline
Super Moderator
 
Join Date: Jul 2002
Location: Long Island USA
Posts: 36,747
Krewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputation
Quote:
Originally Posted by montey2005 View Post
thanks. I took it to the dealer and it turns out the connector under the headliner rattled loose and it could not be fitted back on so a new one was put in. I guess too much off-roading but I'd rather find these items now while it's under warranty.
Excellent! Good luck with it
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
03 Navigator Radio Bignate316 Expedition & Navigator 0 05-25-2014 07:33 PM
Switched 12 volt connection?? mwells 2007 - 2014 Expedition & Navigator 7 05-20-2014 11:28 PM
2010 Platinum 32000 mile report Rifboy 2009 - 2014 F150 11 03-31-2011 06:14 PM
Updating the factory GPS rowekmr Explorer, Sport Trac, Mountaineer & Aviator 5 04-22-2010 06:05 PM
Update GPS nut1605 2009 - 2014 F150 2 06-17-2009 03:30 PM


Go Back   Ford Truck Enthusiasts Forums > >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 09:07 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.