Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 08-28-2013, 12:53 PM
jamull2852 jamull2852 is offline
Junior User
 
Join Date: Mar 2013
Posts: 58
jamull2852 is starting off with a positive reputation.
Expedition code P0340 and P0344

Truck already has the ticking noise I guess from the phasers, but it started sounding like a loud tractor and I got these two codes which I understand are the cam shaft sensor. Is this something I can easily fix or is it better to bring to mechanic. I see some people say you dont have to be in Top Dead Center and some say yeah? Truck is a 2007 expedition limited with 130k miles on it.
Reply With Quote
  #2 (permalink)  
Old 09-08-2013, 08:59 AM
dgruhlke dgruhlke is offline
New User
 
Join Date: Aug 2011
Posts: 15
dgruhlke is starting off with a positive reputation.
Had the same deal

Had the same thing happen to my 2007 Expy while at Disney with my travel trailer. Luckily didn't happen in the middle of nowhere. I took it to the shop and was $200 to replace cam shaft sensor. Not much $, never bothered looking to see how to do it myself since I was on vacation and had no tools.
Reply With Quote
Old 09-08-2013, 08:59 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 expedition danny2313 Modular V8 (4.6L, 5.4L) 1 01-09-2014 01:42 PM
Truck stumbels in OD, also P0705 code 99_expedition Expedition & Navigator 0 05-05-2013 02:46 PM
'99 Expedition XLT deadpool1130 Expedition & Navigator 4 03-24-2013 10:59 PM
Ford Expedition 2001 Codes P0174 , P0172 msradio Expedition & Navigator 2 01-22-2013 08:16 AM
21 OBDII Codes!!?? iateatoad Expedition & Navigator 13 12-08-2012 10:35 PM



All times are GMT -5. The time now is 01:22 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup