A/c blower motor quit. 2009 expedition - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Log In 


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

A/c blower motor quit. 2009 expedition

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-22-2013, 07:03 PM
f100today's Avatar
f100today f100today is online now
Posting Guru
 
Join Date: Jul 2011
Location: DFW Texas
Posts: 1,413
f100today is gaining momentum as a positive member of FTE.f100today is gaining momentum as a positive member of FTE.
A/c blower motor quit. 2009 expedition

Sitting in the expedition a minute ago and all the sudden the air conditioner fan quit Blowing. The rear still blows cold and functions correctly. Should I assume this is just the blower motor or might there be a relay involved? R and r of the blower difficult?
Reply With Quote
  #2  
Old 08-22-2013, 07:05 PM
f100today's Avatar
f100today f100today is online now
Posting Guru
 
Join Date: Jul 2011
Location: DFW Texas
Posts: 1,413
f100today is gaining momentum as a positive member of FTE.f100today is gaining momentum as a positive member of FTE.
Guess I should check fuses first.
Reply With Quote
  #3  
Old 05-19-2014, 07:43 PM
pugster pugster is offline
Senior User
 
Join Date: Aug 2007
Posts: 201
pugster is starting off with a positive reputation.
Curious how your problem worked out?

My 2008 F250 quit blowing and will not provide any cold air on recirc.

I hit a 150 lb hog Saturday morning, but the air still worked fine until last nite - don't know if related.
__________________
2008 F250SD Lariat, 4x4, 6.4L, TorqShift, Job 1 93,000 miles.
Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
blower motor 2010 stx f150STX27 New Member Introductions 1 04-21-2016 04:33 PM
AC fan ? garagegods 1987 - 1996 F150 & Larger F-Series Trucks 0 07-05-2015 01:54 PM
No heat/air blowing from front vents of '03 Expedition XLT coachblue502 Expedition & Navigator 9 05-05-2015 04:53 AM
Fan Motor works off and on... Polkster 1999 - 2003 7.3L Power Stroke Diesel 7 09-06-2014 09:39 PM
AC Intermittent Issue Craig.Parks 2007 - 2014 Expedition & Navigator 1 08-18-2014 07:53 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 03:02 PM.

 

Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup