94 ranger 2.3 pleas help - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Other Ford Engines > 4 Cylinder Engines
Log In 


94 ranger 2.3 pleas help

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-17-2013, 09:48 PM
stevesecoy stevesecoy is offline
New User
 
Join Date: Aug 2013
Posts: 2
stevesecoy is starting off with a positive reputation.
94 ranger 2.3 pleas help

Okay Heres The Problem, Im Getting Fuel To The Rail, Getting Fire, But My Truck Wont Run.If I Spray Ether Into The Intake It Will Run As LOng As Im Spraying But Dies When I Quit.. I ReplCed The Fuel Pump, The EEc,Both Relays And ChEcked All Fuses! Please Any Suggestions
Reply With Quote
  #2  
Old 08-24-2013, 08:21 PM
thunder74-79's Avatar
thunder74-79 thunder74-79 is offline
Junior User
 
Join Date: Feb 2012
Posts: 58
thunder74-79 is starting off with a positive reputation.
sounds like your injectors aren't firing.
Reply With Quote
  #3  
Old 10-02-2013, 10:04 AM
Stinky1 Stinky1 is offline
Junior User
 
Join Date: Dec 2012
Location: Whitewater, CO
Posts: 65
Stinky1 is starting off with a positive reputation.
Have you checked your fuel pressure?

If you have pressure, then your injectors ain't working...like Thunder said.

"Something" tells the injectors to get with it, get working, NOW!!! It could be the computer, it could be a sensor, whatever it is...start there.
Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0171 Code only, coughing and running rich jollyradar 1999 to 2016 Super Duty 5 04-26-2015 03:58 PM
1986 F250 6.9L no start twistedcherokee Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 12 12-06-2014 02:19 AM
94 f150 fuel filter fordka 1987 - 1996 F150 & Larger F-Series Trucks 3 06-06-2014 03:37 PM
Found the Vacuum Leak rocknrod 1997 - 2003 F150 5 04-02-2014 10:42 AM
Start problems/1986 F250 DarolWester 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 32 08-13-2013 07:59 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Other Ford Engines > 4 Cylinder Engines

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 02:19 AM.

 

Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup