Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Other Ford Engines > 4 Cylinder Engines
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-17-2013, 10:48 PM
stevesecoy stevesecoy is offline
New User
 
Join Date: Aug 2013
Posts: 2
stevesecoy is starting off with a positive reputation.
94 ranger 2.3 pleas help

Okay Heres The Problem, Im Getting Fuel To The Rail, Getting Fire, But My Truck Wont Run.If I Spray Ether Into The Intake It Will Run As LOng As Im Spraying But Dies When I Quit.. I ReplCed The Fuel Pump, The EEc,Both Relays And ChEcked All Fuses! Please Any Suggestions
Reply With Quote
  #2  
Old 08-24-2013, 09:21 PM
thunder74-79's Avatar
thunder74-79 thunder74-79 is offline
Junior User
 
Join Date: Feb 2012
Posts: 58
thunder74-79 is starting off with a positive reputation.
sounds like your injectors aren't firing.
Reply With Quote
  #3  
Old 10-02-2013, 11:04 AM
Stinky1 Stinky1 is offline
Junior User
 
Join Date: Dec 2012
Location: Whitewater, CO
Posts: 65
Stinky1 is starting off with a positive reputation.
Have you checked your fuel pressure?

If you have pressure, then your injectors ain't working...like Thunder said.

"Something" tells the injectors to get with it, get working, NOW!!! It could be the computer, it could be a sensor, whatever it is...start there.
Reply With Quote
Old 10-02-2013, 11:04 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 ranger 2.3 please helpcm stevesecoy Fuel Injection, Carburetion & Fuel System 1 08-18-2013 09:00 PM
Help! fuel injector prob countryboy40380 1987 - 1996 F150 & Larger F-Series Trucks 7 07-16-2012 11:49 AM
I want to spray, what fuel system? 06silvercrew 6.0L Power Stroke Diesel 6 02-15-2009 10:34 PM
86 with 302 no start cutt 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 2 12-31-2003 02:31 PM
power service additive buckford Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 1 12-29-2003 11:13 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Other Ford Engines > 4 Cylinder Engines

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 04:13 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup