Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty
Sign in using an external account
Register Forgot Password?


Super Duty & Heavy Duty 1999 to current Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-15-2013, 08:28 PM
edpare edpare is offline
New User
 
Join Date: Oct 2012
Posts: 2
edpare is starting off with a positive reputation.
Weird charging issue F350 6.0 diesel

This is a stumper for me: To end with, I'm on my 4th alternator in 9 months. Ford OEM, Ford remanufactured, Chinese, and lastly new Bosch HD. There are 4 different things happening when the red charging icon lights up after starting: the icon comes on, system voltage stays at 12.2v until I stop the engine, let it cool off, and restart. or 2) the light comes on after starting, system voltage is 12.2v until the alternator goes up to 13.6v after 10 minutes or so, and the light stays on until restart. or 3) the light goes on after start, system voltage at 12.2v until the alternator starts charging at 13.6 v and the light goes out by itself. But lately, 4) the light comes on, even though I'm getting 13.6v 90 seconds after start.
It looks like the charge idiot light isn't connected to the alternator!
Anybody?
Reply With Quote
Old 08-15-2013, 08:28 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alternator/voltage/charging JR2980 Excursion - King of SUVs 17 07-24-2014 02:25 PM
Alternator Only Charges Full Battery - Stumped lign Excursion - King of SUVs 29 10-19-2013 01:37 PM
HELP! Major elec. problem, Ex won't start, battery draw w/ key off 12valveEx Excursion - King of SUVs 10 08-16-2013 08:24 PM
Basic PS7.3 Charging Questions Taggert 1999 - 2003 7.3L Power Stroke Diesel 4 07-16-2013 03:22 PM
Check Charging System a11m1ghty Expedition & Navigator 2 08-22-2012 07:45 PM



All times are GMT -5. The time now is 12:03 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup