Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-11-2013, 09:32 AM
al73mustang al73mustang is offline
New User
 
Join Date: May 2011
Posts: 1
al73mustang is starting off with a positive reputation.
2010 EL Limited rear blower no power

I have checked every fuse and even checked for power at the blower motor connection and nothing. Has anyone ran into this problem? it was working fine on Friday then nothing the next day! Front A/C works fine. Thanks for any help cant find anything on the net.
Reply With Quote
Old 08-11-2013, 09:32 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blower stopped working bill57 1997 - 2003 F150 7 06-18-2014 06:46 AM
72 F-250 Blower motor help donp390 1967 - 1972 F-100 & Larger F-Series Trucks 8 01-12-2014 05:25 PM
Van Blower Motor - No Power clifjen Cooling, Heating, Ventilation & A/C 18 11-12-2013 07:43 PM
blower not work? Super Econoline 1968-2013 Full Size Vans 17 05-18-2013 08:34 PM
ac will not run and it's 109 degrees outside! rcummings Super Duty & Heavy Duty 5 08-03-2012 04:35 PM



All times are GMT -5. The time now is 01:20 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup