Go Back   Ford Truck Enthusiasts Forums > Ford Vans and other vehicles > 2014+ Transit
Sign in using an external account
Register Forgot Password?


2014+ Transit 2014+ full size Ford Transit Van, Wagon, Cutaway and Chassis-Cab

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-09-2013, 10:47 AM
Bodine57 Bodine57 is offline
New User
 
Join Date: Aug 2013
Posts: 3
Bodine57 is starting off with a positive reputation.
Question Old issue needs updated

I have a 4.2 in a 2000 E150. after 15-20 mins. driving, temp guage goes up. No fluid loss, and burping & running heater to dissipate heat helps. Cool nights not as serious effect. Radiator, pump, & thermo. changed by previous owner. I changed fan clutch, 2nd thermo., cap, & pressure washed condensor and radiator. Door chime continues after driving starts, ABS light on after driving short time, & oil temp light comes on with rising temp guage. It powered down the first time I drove it a distance and had these problems. Limped it back and above work done since. Have seen the posts here but nothing relevent since first of the year and no solutions. Anyone with fresh ideas? Cool driving weather you don't see as much.
Reply With Quote
  #2  
Old 08-09-2013, 10:52 AM
Bodine57 Bodine57 is offline
New User
 
Join Date: Aug 2013
Posts: 3
Bodine57 is starting off with a positive reputation.
The 4.2 runs great but does get a little rough running as temp goes up. Are there any coolant flow valves I'm unaware of? All lines heat up & heater & air works. Read about sensors for temp guage & computer but no changes yet.
Reply With Quote
  #3  
Old 08-12-2013, 09:20 PM
Club Wagon Club Wagon is offline
Posting Guru
 
Join Date: Feb 2007
Posts: 2,351
Club Wagon is gaining momentum as a positive member of FTE.
How about posting these questions in the '1968-2013 Full Size Van' (Econoline) section - NOT the '2014+ Transit' section?

Quote:
Originally Posted by Bodine57 View Post
Anyone with fresh ideas?
Reply With Quote
Old 08-12-2013, 09:20 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running Hot! fordlover302 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 28 07-28-2011 10:41 PM
1999 ford expedition overheat ericjoes03 Expedition & Navigator 4 04-26-2011 06:50 PM
Another EOT vs. ECT thread? SFC-REMF 6.0L Power Stroke Diesel 6 12-07-2010 08:46 PM
Truck Running Cold... Please Help JML31 Cooling, Heating, Ventilation & A/C 1 10-03-2010 07:09 PM
people with horizontal radiator cores look here f100guy Cooling, Heating, Ventilation & A/C 1 04-03-2004 09:52 PM


Go Back   Ford Truck Enthusiasts Forums > Ford Vans and other vehicles > 2014+ Transit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 08:26 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup