Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.7L Power Stroke Diesel
Sign in using an external account
Register Forgot Password?


6.7L Power Stroke Diesel 2011-2015 Ford Powerstroke 6.7 L turbo diesel engine

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-08-2013, 03:42 PM
mebe2k's Avatar
mebe2k mebe2k is offline
Elder User
 
Join Date: Dec 2003
Posts: 602
mebe2k is starting off with a positive reputation.
P026A - anyone had this code show up?

took my new/old 36' 5th wheel for it's first trip from Phoenix, AZ to Laughlin, NV.. truck ran very well and pulls the hills great...gets about 8-10 mpg while pulling the 12K trailer..however...on the way back, stopped for fuel in Kingman, AZ, got on i40 and had the Check Engine/MIL light come on.. first thought was, not another stupid EGT sensor...stopped into Jones Ford in Wickenburg, AZ, and the mechanic came out and hooked his laptop up and started scanning for codes..P026A - Charge Air Cooler Efficiency Below Threshold - comes up. the mechanic said that it's probably a sensor for the air charge cooler...but he would need the truck overnight to check for sure..I asked him if it would be alright to keep on going to Phoenix..he said yes, that it might have got too hot and that is why it set that code(it was very hot 110+)..he cleared the code and I was on my way back to phoenix..

Well... took the trailer for a trip up to Utah, and not even 1/4 way into the trip, the MIL/Check engine light comes on again..checked it with my OBD/CAN scanner and P026A again...looks like another trip to the dealer. the problem doesn't seem to change the way the engine runs, although it seemed like it was getting lower MPG's, after the MIL/check engine light came on..anyone else had this code/issue come up? the mechanic at jones ford said this was the first time he had seen this code come up on a 6.7..
__________________
2011 F350 4x4 CC 6.7L PSD..
1988 Ranger STX 4x4 2.9L 5-speed
2006 Escape XLT 3.0L
1977 F150 Ranger Supercab 460/C6 2wd
Reply With Quote
  #2  
Old 07-30-2013, 11:10 PM
Howard.Judd Howard.Judd is offline
New User
 
Join Date: Jul 2013
Posts: 1
Howard.Judd is starting off with a positive reputation.
I had that code turn up on mine today. The tech at my local dealer checked the troubleshooting manual and it said to first check the coolant level in the secondary cooling system. He did and mine was very low. Topped it off with coolant, cleared the code and all is well for now. Bad thing is he also told me the only time he had ever seen one lose coolant from the secondary cooling system it was because the EGR cooler was leaking. So, I'm going to monitor the level for a couple of days and check for external leaks before I take it back. At least I think it's still covered under warranty.
Reply With Quote
  #3  
Old 07-31-2013, 02:02 PM
mebe2k's Avatar
mebe2k mebe2k is offline
Elder User
 
Join Date: Dec 2003
Posts: 602
mebe2k is starting off with a positive reputation.
Mine was the sensor for the air charge cooler.. Just like the first mechanic said..ford must've used some really cheesy sensors on these trucks.. SO far 2 egt sensors and now the air charge cooler sensor,.
Reply With Quote
Old 07-31-2013, 02:02 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help - Need a good Mechanic in the Phoenix, AZ area JulieM80 1968-2013 Full Size Vans 2 03-05-2013 01:53 PM
Crazy good mileage on this last trip?? scottman70 Excursion - King of SUVs 7 06-23-2010 08:15 AM
need a good diesel mechanic!!! farmlucki 1999 - 2003 7.3L Power Stroke Diesel 1 03-16-2007 12:33 AM
Attention FTE Peeps Mil1ion New Member Introductions 3 01-24-2005 12:43 PM
First Tow - Successful! Cowboy Brett 6.0L Power Stroke Diesel 1 05-27-2004 09:27 AM


Go Back   Ford Truck Enthusiasts Forums > Diesel > 6.7L Power Stroke Diesel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 11:31 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup