Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 06-26-2013, 08:05 AM
Partime Partime is offline
New User
 
Join Date: May 2013
Posts: 18
Partime is starting off with a positive reputation.
2008 expedition transmission

when towing my camper with my 2008 expedition limited EL my tranny seems to whistle when going uphill. but not all the time. sometimes it seems to rev up but the tach wont move either. kinda like it downshifts but rpms does not go up. any ideas on what this could be
Reply With Quote
  #2 (permalink)  
Old 06-27-2013, 01:08 AM
go-part go-part is offline
Former Vendor
 
Join Date: Feb 2013
Posts: 39
go-part is starting off with a positive reputation.
What does the transmission fluid look like and is it the correct amount?
Reply With Quote
  #3 (permalink)  
Old 06-27-2013, 01:16 AM
Partime Partime is offline
New User
 
Join Date: May 2013
Posts: 18
Partime is starting off with a positive reputation.
I will check that out and get back with ya in the AM
Reply With Quote
  #4 (permalink)  
Old 06-27-2013, 11:06 PM
montecarlo31 montecarlo31 is offline
Elder User
 
Join Date: Sep 2004
Posts: 536
montecarlo31 is starting off with a positive reputation.
are you sure it's actually the transmission and not the cooling fan ramping up as more airflow is needed? I know on my 07 (maybe 08) EL 4x4 and 9,000 lbs in tow that cooling fan was screaming in traffic or going up hill.
Reply With Quote
  #5 (permalink)  
Old 06-27-2013, 11:38 PM
Partime Partime is offline
New User
 
Join Date: May 2013
Posts: 18
Partime is starting off with a positive reputation.
Probably is the cooling fan. It sure screams. I just dont know what the whistling or ringing noise is. It does that sometimes even when the fan isnt screaming. I looked under the hood to check transmission fluid. Couldnt find the dipstick. Where is it
Reply With Quote
  #6 (permalink)  
Old 06-28-2013, 05:25 PM
montecarlo31 montecarlo31 is offline
Elder User
 
Join Date: Sep 2004
Posts: 536
montecarlo31 is starting off with a positive reputation.
Quote:
Originally Posted by Partime View Post
Probably is the cooling fan. It sure screams. I just dont know what the whistling or ringing noise is. It does that sometimes even when the fan isnt screaming. I looked under the hood to check transmission fluid. Couldnt find the dipstick. Where is it
not under the hood. You need to crawl under it. Trans is a sealed unit with a fill / level plug on the side.

It could also be an idler going bad as well. I'd like to hear / see a video to give a good idea of what's going on.
Reply With Quote
Old 06-28-2013, 05:25 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New guy from the desert slhanks4 New Member Introductions 4 05-21-2014 10:23 AM
Connect my IPhone to 2008 Expedition. Crystaleth 2007+ Expedition & Navigator 5 12-07-2013 01:00 PM
2008 Expedition - Hazards coming on DK_in_SD 2007+ Expedition & Navigator 1 11-02-2013 11:21 AM
Programmer for 2008 expedition Ricky Guerra Computer Chips & Tuners 2 08-30-2013 08:53 AM
2008 Expedition Subwoofer... smoakncop 2007+ Expedition & Navigator 4 09-01-2012 11:07 AM



All times are GMT -5. The time now is 05:35 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup