Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 06-22-2013, 09:17 PM
gpfarrell gpfarrell is offline
Senior User
 
Join Date: Nov 2004
Location: Pittsburgh!
Posts: 296
gpfarrell is starting off with a positive reputation.
Air Suspension S.O.S... Broken 500 miles from home!

We drove our 2007 Navigator L 540 miles today from Pittsburgh to Outer Banks, NC.

Along the way the air suspension failed. Our Navi has 67,000 miles and it is 7 years old, so maybe it was due to fail. We hit an especially rough section of the Pennsylvania turnpike, maybe the series of expansion joints caused it. I dunno.

I've got my wife and 3 boys (ages 9,7, & 4) with me.

The Navi was fairly loaded, plus we had a bike rack hanging off the hitch with 5 bikes on it. I doubt I exceeded the 600 lb tongue weight, but with the leverage of the bike rack I may have been close.

The good news is I still have some air in the system. My rear end is lower than normal, but not bottoming out. At one red light the compressor was running continually, much longer than normal. At the next light I got a notice on the dash that said "Air Suspenion not functioning" or something close to that. I haven't heard the compressor since.

I turned the system off and left it off for 50 miles, but it wouldnt come back to life when I turned it back on.

Later we unloaded the vehicle but the system still won't work.

Any ideas? I'd love to swap a fuse or hit a reset button, but I'm fearful my Lincoln and I might spend our vacation at the mercy of the local Ford dealer if we are going to have a safe ride home.

Thanks for any ideas!
__________________
1997 F250HD 4wd, 460-5-speed Ext. Cab, Blue
2007 Navigator L Dark Blue Pearl
2003 Mercury Marauder, Dark Blue Pearl, Trilogy Supercharged, 13.1 @ 105
Reply With Quote
  #2 (permalink)  
Old 06-25-2013, 07:53 AM
jp4lsu jp4lsu is offline
New User
 
Join Date: Jun 2013
Posts: 12
jp4lsu is starting off with a positive reputation.
GPF,
I don't have a quick fix for you. It sounds like a leaky system. But I would recommend taking out the air ride and swap in a coil over replacement. Eibach make a kit for all 4 corners for around $500.

I doubt this is an option fo you now, but I would think about when you get home or the next time you have an issue.
Reply With Quote
  #3 (permalink)  
Old 06-25-2013, 11:18 AM
alwaysfords41's Avatar
alwaysfords41 alwaysfords41 is offline
Posting Guru
 
Join Date: Feb 2008
Posts: 1,734
alwaysfords41 is gaining momentum as a positive member of FTE.
My 2 cents, you are on vacation and the less time you worry about this the better. Find a dealer and bring it in, get a loaner vehicle from them (hopefully) or get them to set up a rental through whatever place they use because it is dirt cheap that way, and go vacation. no need to waste time on the back and forth here.
__________________
2010 Expedition Limited now @ 27k
2012 Expedition Limited now @ 17k
Gone but not forgotten;
1995 Bronco XLT, 1996 Explorer XLT, 1999 Expedition EB, 2003 Expedition EB, 2004 Expedition EB Premium
Reply With Quote
  #4 (permalink)  
Old 06-28-2013, 07:59 PM
gpfarrell gpfarrell is offline
Senior User
 
Join Date: Nov 2004
Location: Pittsburgh!
Posts: 296
gpfarrell is starting off with a positive reputation.
Quote:
Originally Posted by alwaysfords41 View Post
My 2 cents, you are on vacation and the less time you worry about this the better. Find a dealer and bring it in, get a loaner vehicle from them (hopefully) or get them to set up a rental through whatever place they use because it is dirt cheap that way, and go vacation. no need to waste time on the back and forth here.
Winner winner chicken dinner!

That's exactly what we did. The nearest dealership was 41 miles away in Manteo, NC but they had it diagnosed in an hour and fixed in a day. It needed a compressor and the resistor died as the compressor labored, so it got one of those too. Got a rental and got back to the sand, so it all worked well.
__________________
1997 F250HD 4wd, 460-5-speed Ext. Cab, Blue
2007 Navigator L Dark Blue Pearl
2003 Mercury Marauder, Dark Blue Pearl, Trilogy Supercharged, 13.1 @ 105
Reply With Quote
Old 06-28-2013, 07:59 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bike rack mounting questions FordmanNJ Towing, Trailers & 5th Wheels 14 08-13-2014 11:08 PM
O/D light flashing, no TC lockup, possibilities? jeffreyt 1999 - 2003 7.3L Power Stroke Diesel 25 07-22-2014 10:02 PM
Dentside owner in Pittsburgh area? Carter78F150 1973 - 1979 F-100 & Larger F-Series Trucks 5 04-18-2014 06:29 PM
Transmission/TPS issue? M992wd Super Duty & Heavy Duty 14 03-08-2014 11:08 PM
Water pump went out Furniture Doctor 1994.5 - 1997 7.3L Power Stroke Diesel 5 09-01-2013 04:05 PM



All times are GMT -5. The time now is 11:25 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup