Go Back   Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1987 - 1996 F150 & Larger F-Series Trucks
Sign in using an external account
Register Forgot Password?


1987 - 1996 F150 & Larger F-Series Trucks 1987 - 1996 Ford F-150, F-250, F-350 and larger pickups - including the 1997 heavy-duty F250/F350+ trucks

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-11-2013, 01:27 AM
93_pos 93_pos is offline
New User
 
Join Date: Jun 2013
Posts: 3
93_pos is starting off with a positive reputation.
truck needs help!!!

Hi, so I work for this guy and totaled my last work truck. So his wife's grandfather had passed years and years ago. He bought brand new a 92 f150 4x4 5.0, well he passed and truck sat for the last 15 years in a garage. We picked truck up with 26,000 original Miles.got truck home and did a few things before trying to start,
Changed oil&filter,replaced both tanks & fuel pumps, new fuel filter, plugs wires cap and button and air filter.Started right up and ran OK I guess. Well its been a year now and has 40,000 miles now everything was replaced to be safe on the road. It has a rough idle and will not rev past 3000 rpm feels like a slight miss cruising around 50 mph. I know its not going to be fast but this sucks. Why would it do this? Could a cat be bad? Have smelled rotten eggs when I had a little load on truck. Gas millage is around 10 hwy and 13 city.
The exhaust pipe looks like truck sits. No black just rusty looking and I drive several hundred miles a week.
Reply With Quote
  #2  
Old 06-11-2013, 07:15 AM
Intimnasc's Avatar
Intimnasc Intimnasc is offline
Senior User
 
Join Date: Apr 2012
Location: Fort Worth, Texas
Posts: 421
Intimnasc is gaining momentum as a positive member of FTE.
Some low hanging fruit you may look into would be the fuel filter or maybe even the injectors beinbg dirty if you didnt flush the fuel lines. Get a code reader and check for codes. What transmission is in it?
Reply With Quote
  #3  
Old 06-11-2013, 10:43 AM
93_pos 93_pos is offline
New User
 
Join Date: Jun 2013
Posts: 3
93_pos is starting off with a positive reputation.
Trans I don't know it has O/D and 4x4 if it matters... AOD?
No didn't flush lines to motor just from tank to filter. What can I try to clean injectors without removing them? Do you know what redline would be for this truck is this truck not meant to go over 3k. Rpm.
Reply With Quote
  #4  
Old 06-11-2013, 10:48 AM
buzzy613 buzzy613 is offline
Elder User
 
Join Date: Apr 2012
Location: Munger
Posts: 508
buzzy613 is starting off with a positive reputation.
5.0 hits 5500rpm no problem i would deffinatly look in to the cat could be a rats nest in it
__________________
Zach
1996 F-250 aka Ol' RED 351W/5.8 2.25 true dual exhaust, K&N filter, home made bull guard, and more to come!
Reply With Quote
  #5  
Old 06-11-2013, 11:09 AM
93_pos 93_pos is offline
New User
 
Join Date: Jun 2013
Posts: 3
93_pos is starting off with a positive reputation.
Say it was a nest wouldn't I have blown it out by now? Its been 14k miles. I can feel exhaust on my hand about a foot away if that means anything.
Reply With Quote
  #6  
Old 06-11-2013, 11:13 AM
buzzy613 buzzy613 is offline
Elder User
 
Join Date: Apr 2012
Location: Munger
Posts: 508
buzzy613 is starting off with a positive reputation.
not nessicaraly it could be pluged and still flow just not goodits like a honey comb in side the cats
__________________
Zach
1996 F-250 aka Ol' RED 351W/5.8 2.25 true dual exhaust, K&N filter, home made bull guard, and more to come!
Reply With Quote
  #7  
Old 06-11-2013, 11:24 AM
92cruisinblue's Avatar
92cruisinblue 92cruisinblue is offline
Junior User
 
Join Date: Mar 2013
Location: mt airy, georgia
Posts: 51
92cruisinblue is starting off with a positive reputation.
I have the same truck, 92 5.0 4x4 automatic and when I got mine it had been sitting for a little over a year. Mine wouldnt even rev passed 2200 rpm, it would just lose all power and drop rpms, and mine was due to TPS and ALOT of build up in the throttle body and upper intake
__________________
1992 F-150 4x4, 5.0, Hedman Headers, 2.25 True Duals w/ Glass Packs, E4OD, 6'' RC lift, 35'' BFG ATs
Jesus Saves, Walk by Faith
Reply With Quote
  #8  
Old 06-11-2013, 11:36 AM
RedDragon777's Avatar
RedDragon777 RedDragon777 is offline
Senior User
 
Join Date: Nov 2007
Location: Mercedes, TX
Posts: 372
RedDragon777 is starting off with a positive reputation.
Have you checked the Throttle Position Sensor. On my wife's '90 4.9L the truck would not idle sometimes and when it did it would not rev past 2200 RPM and it would buck really bad when driving. I replaced the front fuel pump and the TPS along with all the normal maintenance parts and it runs like a dream now and this truck is close to hitting 484,000 miles. I also recommend like everyone else and get the Innova 3145 code reader. It was the best $34 i spent and it helped me track down all the problems with the truck.
__________________
1990 F-150 4.9L SC SB Lariat 4x2 (Wifes)
1997 F-250 5.4L SC XLT Light Duty 4x4
2006 Mustang GT
2012 Focus SE Sport
Reply With Quote
  #9  
Old 06-11-2013, 12:03 PM
Encho's Avatar
Encho Encho is offline
The Brown Mod
 
Join Date: Dec 2004
Location: Caracas, Venezuela
Posts: 6,036
Encho has a brilliant futureEncho has a brilliant futureEncho has a brilliant futureEncho has a brilliant futureEncho has a brilliant futureEncho has a brilliant futureEncho has a brilliant futureEncho has a brilliant futureEncho has a brilliant futureEncho has a brilliant futureEncho has a brilliant future
See if the cat is plugged, and you could try running some Seafoam through the system to clean all the deposits.
__________________
1993 Special Edition Bronco: 5.0lt V8, E4OD Auto, MM Supreme manual hub lockers and a sweet roof tent, ROTW in 2/9/09
My Write-ups: Ford Steering Box Rebuild / Ford Front End Rebuild and auto hubs replacement / Ford Rear Drum Brakes / Ford E4OD Cooler & Shift Kit mods, drain-refill procedures R.I.P. Steve, you will be deeply missed my friend
Reply With Quote
Old 06-11-2013, 12:03 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
'04 5.4l Triton F150 running rough & ticking noise while idling after warming up HelloMoto 2004 - 2008 F150 0 11-21-2013 04:21 AM
Filter Clogging on something/Getting SVO parts Orpackrat Bio-diesel, Propane & Alternative Diesel Engine Fuels 15 09-16-2013 06:09 PM
62 Ford F100 keeps dying! maura 1961 - 1966 F-100 & Larger F-Series Trucks 5 11-12-2012 02:35 AM
Bad fuel pump? jspringator Excursion - King of SUVs 5 11-02-2012 03:46 PM


Go Back   Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1987 - 1996 F150 & Larger F-Series Trucks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 01:51 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup