Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 05-29-2013, 05:15 PM
Joey White Joey White is offline
New User
 
Join Date: May 2013
Posts: 1
Joey White is starting off with a positive reputation.
Unique CD changer issue

We have a 2007 EL that has a 6 disc changer (no nav). The cd motor will come on randomly in various "input" modes. In other words, we can be driving down the road listening to Sirius and the CD motor suddenly kicks on and cycles through as if it is trying to load or switch CDs. We don't listen to CDs, but what has us concerned is that this has happened with two other units that the dealer has replaced for us. My worry is that it is a ground/electrical issue somewhere. We did have a dead battery, but not certain the battery issue was directly related to this.

Any thoughts?
Reply With Quote
  #2 (permalink)  
Old 05-29-2013, 06:31 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,007
berry1234 is gaining momentum as a positive member of FTE.
It's a common glitch. My 07 and 08 do this randomly. Had two units replaced, same bug. It's in the design. I just ignore it. Happens about once a month that I notice.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
Old 05-29-2013, 06:31 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 11:21 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup