Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-20-2013, 06:44 PM
idipwr idipwr is offline
New User
 
Join Date: Feb 2008
Posts: 10
idipwr is starting off with a positive reputation.
99 5.4 locked up?

Friend of mine has a 99 f150 w/ a 5.4. Was running
Fine till one day wouldn't start. Like it wouldn't turn over
Then got it started and seemed to run fine for a few days
Till one day wouldn't start again. Had a shop look at it, and they said
The motor is locked up, can bar it over backwards but not forward?
Any ideas?? I'm going to check it out when he gets it
Back. What should I look for. Is the motor doa?
Reply With Quote
Old 05-20-2013, 06:44 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery acts dead- then fine? mattri 1987 - 1996 F150 & Larger F-Series Trucks 13 06-20-2014 09:34 PM
2002 5.4L Expedition no oil pressure shut down now has pressure john08007 Expedition & Navigator 1 08-21-2013 02:49 PM
No power to the OBD-II port Averic04 Super Duty & Heavy Duty 2 06-08-2013 10:33 AM
Gutless till warms up no codes HELP chris05 6.0L Power Stroke Diesel 3 06-03-2013 04:19 PM
Start issues, 05' 6.0 f250 Bbow8889 Super Duty & Heavy Duty 0 12-04-2012 10:54 AM



All times are GMT -5. The time now is 03:27 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup