Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-30-2013, 10:34 PM
Sweetpea02 Sweetpea02 is offline
Freshman User
 
Join Date: Apr 2006
Posts: 28
Sweetpea02 is starting off with a positive reputation.
2008 Expe Rear View Camera

Hi, I have a 2008 Expedition KR with the rear view camera in the mirror.
Camera was working good until this weekend.The picture got real light
them would fade to nothing. Today it will not go on at all.
Could be the camera or monitor in mirror. Is it wireless or is there a cable
that I could check for connection, anybody know the routing of the cable ?

Thanks
Reply With Quote
  #2  
Old 05-01-2013, 02:35 PM
cstanley44's Avatar
cstanley44 cstanley44 is offline
Junior User
 
Join Date: Jun 2011
Location: Orlando, FL
Posts: 95
cstanley44 is gaining momentum as a positive member of FTE.
I had issues like you describe but the mirror always showed something... light, dark, flickering etc..

It seemed like I could tap on the camera and it would correct itself, but on the next start it would not work

I removed the door panel on the lift gate and found the wiring harness really loose on the camera. I made sure it was on tight and taped it with electric tape. That was a year ago and Ive not had any issues since.
__________________
Curtis
````````````````````````
2008 Expedition EL Limited
2004 Explorer XLT 4x4 4.6
1970 Buick GS 455 Silver Mist
Reply With Quote
  #3  
Old 05-01-2013, 05:58 PM
Sweetpea02 Sweetpea02 is offline
Freshman User
 
Join Date: Apr 2006
Posts: 28
Sweetpea02 is starting off with a positive reputation.
Hi, yesterday I had nothing in mirror.
This morning, I could see the green, yellow & red guide line with a
bunch of statics, like old black and white TV.
It started acting up Sunday after I used the tailgate, so as you suggested
I will start there.

Thanks
Reply With Quote
  #4  
Old 06-06-2013, 10:23 PM
phnguyk phnguyk is offline
Junior User
 
Join Date: Jul 2011
Posts: 75
phnguyk is gaining momentum as a positive member of FTE.
The '08's camera on my parents acted up, bang tailgate near cam and it would come back. Ended up replacing the camera, the one that came out, the wiring plugged right into the camera. The replacement we ordered the cord was hardwired with a plug on the end, like a short dongle. They haven't had any issues since.
Reply With Quote
  #5  
Old 06-07-2013, 10:04 PM
Sweetpea02 Sweetpea02 is offline
Freshman User
 
Join Date: Apr 2006
Posts: 28
Sweetpea02 is starting off with a positive reputation.
It did not work for about one week, then come on and has work ever since.
I don't remember if I opened and closed the liftgate during that time.

Thanks for the replies
Reply With Quote
Old 06-07-2013, 10:04 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
OEM Navigation and back up camera kdokey 2007 - 2014 Expedition & Navigator 0 03-17-2014 03:12 PM
Getting the Back-Up Camera to Stay On All the Time? ExpeditionJim 2007 - 2014 Expedition & Navigator 3 04-24-2011 01:26 PM
Back Up Camera i_love_paintbal 1997 - 2003 F150 1 04-09-2010 01:38 PM
Rear View Camera fire3110 2007 - 2014 Expedition & Navigator 3 10-19-2009 02:02 PM
Rear View Camera fire3110 Audio & Video Systems, Navigation, Satellite Radio & Mobile Electronics 0 10-18-2009 10:09 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 04:35 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup