Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-29-2013, 03:39 PM
MR JDuece MR JDuece is offline
New User
 
Join Date: Apr 2013
Posts: 2
MR JDuece is starting off with a positive reputation.
need help with transmission

i have an 01 5.4 expedition auto trans., as i am driving my truck seems like it slips into neutral, rpms go up but the truck slows down. if i down shift into lower gear im able to go again, then i'll go back into overdrive and it seems fine for a bit shifting through the gears, then a few moments later it seems like im back into neutral. can anyone please help me with diagnoses. will i need a new tranny or is it some internal parts i can change out..
Reply With Quote
  #2  
Old 04-29-2013, 05:18 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 9,459
alloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to allalloro is a name known to all
Not to state the obvious, but did you check the fluid level in Park with the tranny warmed up?
__________________
To thank someone, click the left red "Add to Reputation" button
right of the word "permalink" top right of the poster's message.
Reply With Quote
  #3  
Old 04-29-2013, 09:06 PM
MR JDuece MR JDuece is offline
New User
 
Join Date: Apr 2013
Posts: 2
MR JDuece is starting off with a positive reputation.
yes, the fluid levels were good and i even put lucas stop slip transmission in to see if that would help but it didn't...
Reply With Quote
Old 04-29-2013, 09:06 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hub Stuck Locked + Popped out of 4WD apt403 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 2 09-16-2013 12:37 AM
Truck shifts into neutral grizzly6.0 6.7L Power Stroke Diesel 11 01-17-2012 04:15 PM
how the blazes do I shift? Stephen67 1948 - 1956 F1, F100 & Larger F-Series Trucks 15 07-21-2011 03:00 PM
'94 Auto Gear Selector Lever Suddenly Loose '94Mesquite Clutch, Transmission, Differential, Axle & Transfer Case 3 07-29-2009 03:56 PM
np203 grinding changing gears gsiamrod Clutch, Transmission, Differential, Axle & Transfer Case 0 07-08-2009 05:35 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 06:28 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup