Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty
Sign in using an external account
Register Forgot Password?


Super Duty & Heavy Duty 1999 to current Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-20-2013, 12:38 PM
Shullster32 Shullster32 is offline
New User
 
Join Date: Apr 2013
Posts: 1
Shullster32 is starting off with a positive reputation.
Service Engine Soon Light-need help!

I have a 2000 ford f250 7.3liter 6 speed manual, and i recently just bought a EZ1000 edge chip for my truck. i hooked it up no problem only took a few minutes. started it up and ran great! i ran it for probalby 5 miles and shut it off. I then changed the power level setting to the level 4 (60hp). I then ran my truck for about 15 to 20 miles and it started to shut off on me and i had to pull of to the side of the rode. i had no power stearing or power brakes. I then turned it off, checked then batterie connection, then started it back up and the service engine soon light came on. The chip also wasnt giving me the hp gains, it went back to stock. I took the chip out and still i went to start the truck and the Service Engine Light was on, and still hastn gone off. I plugged the chip back in and it still wasnt working. THen i turned it off and started the truck again and the chip was working, but after about 10 miles it did the same thing and shut off. Please help, idk whether it was still going to happen even if i had not bought the chip, or the chip was the problem. and if so is there a diagnostic for it. Thanks
Reply With Quote
Old 04-20-2013, 12:38 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
need help chip install gone wrong bigtimebubba 1999 - 2003 7.3L Power Stroke Diesel 85 04-30-2008 05:43 PM
need some help. chip install. wont start bigtimebubba Super Duty & Heavy Duty 4 04-25-2008 12:38 AM
The Real Diablo Chip Opinion and Towing Power bcashmoney Computer Chips & Tuners 2 05-23-2003 12:08 AM
serious problem with my superchip tbomb Computer Chips & Tuners 9 09-22-2001 05:51 PM
Diablo Chip ivanwatson Computer Chips & Tuners 2 06-15-2001 08:42 AM


Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 01:50 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup