Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-17-2013, 02:04 PM
ptmares ptmares is offline
New User
 
Join Date: Apr 2012
Posts: 24
ptmares is starting off with a positive reputation.
Transmission or Torque Converter or ???

2007 Expedition with 109k. While driving at a constant speed between 35-55 mph, I get a shuddering like sensation through the cab of the vehicle. More pronounced while climbing a hill.

The feeling is that of a wash board dirt road or rumble strips on the sides of the road. I get another sensation/noise from being stopped on a slight hill and letting the truck roll backwards while in drive. After the hill roll back, still in drive, press the gas (less than 1000rpm's) slightly while going uphill and its as if something releases. Not a loud sound at all. Still felt through the cab.

All fluids changed, tranny, t-case, rear & front diffs. Plugs changed at 101K, and cop's changed 108k.

Any help greatly appreciated.
Reply With Quote
  #2  
Old 04-17-2013, 04:40 PM
montecarlo31 montecarlo31 is offline
Elder User
 
Join Date: Sep 2004
Posts: 539
montecarlo31 is starting off with a positive reputation.
could be anything, I'd not think transmission first. Could be CVs in the front or rear end, could be the brake rotors out of round and warped. Could be a bad ujoint. I'd check the wheel bearings and other suspension parts too while I was at it before I went pulling a trans.
Reply With Quote
Old 04-17-2013, 04:40 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thumping Noise from front end (4WD) dutchnichols Super Duty & Heavy Duty 8 09-26-2014 09:29 PM
Control Issues DogDoc94 Excursion - King of SUVs 6 11-29-2011 10:24 PM
Weird Sensation When Starting/Stopping Wildcat Fan Super Duty & Heavy Duty 16 09-11-2010 07:07 PM
2008 5.4 gas driveline play sensation ciskokid Super Duty & Heavy Duty 11 07-20-2009 12:17 PM
4WD Feels Engaged In 2WD Munkey Super Duty & Heavy Duty 9 02-13-2006 12:39 PM



All times are GMT -5. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup